unable to play some Amazon instant videos on Windows 8

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: juanb, Unassigned)

Tracking

Trunk
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(firefox16-)

Details

(Whiteboard: [win8])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 644366 [details]
some web console output and about support information

Using nightly or 14, 13, 12 I cannot play some Amazon instant videos on a Windows 8 machine with the latest win8 build. I'm running Flash 11.3...265

I can play some movies like Ronin, but I cannot play most movies or series. See Downton Abbey. The player seems be connecting then nothing happens.

I've tried this in safe mode as well. No luck. IE plays just fine.

Steps:
1. Login to your Amazon account
2. Search for Downton Abbey in Amazon Instant Video
3. Select it and then try to play it

Expected: You can play any of those episodes

Actual: Video never loads

Compare this to the movie Ronin where the video does play.
(Reporter)

Updated

5 years ago
Whiteboard: [win8]

Updated

5 years ago
tracking-firefox16: --- → +

Comment 1

5 years ago
I suspect that amazon may be using Flash DRM and there is a DRM issue in the software combo somewhere. I presume this works in Win7?

Can you please test this URL: http://drmtest2.adobe.com/AccessPlayer/player.html ?
The URL in Comment 1 works for me using the Windows 8 RTM, Build 9200 running Firefox 14.0.1.

Comment 3

5 years ago
Juan - would you mind retesting with RTM build?

Updated

5 years ago
QA Contact: jbecerra
Not able to reproduce using the latest Windows 8 Build 9200 using  Mozilla/5.0 (Windows NT 6.2; WOW64; rv:18.0) Gecko/18.0 Firefox/18

I tried the video in Comment 1 and it plays fine, as well as many of the others listed.

Using Flash Version: 11.4.402.265

Comment 5

5 years ago
Given that, I see no need to track. Juan can re-nominate if he runs into this again.
tracking-firefox16: + → -
(Reporter)

Comment 6

5 years ago
This is now working on both Win8 release preview as well as the RTM on nightly and beta using Flash 11.4.402.265.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.