bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

A search from the "awesome bar" goes to mobile google even if User Agent is "Desktop Firefox"

VERIFIED DUPLICATE of bug 783373

Status

()

Firefox for Android
General
VERIFIED DUPLICATE of bug 783373
6 years ago
2 years ago

People

(Reporter: donrhummy, Unassigned)

Tracking

15 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [wontfix?])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

1. Set Add-On Phony to have user agent "Desktop Firefox" 
2. Typed a search "test search" into the address bar and hit enter.


Actual results:

It loaded the mobile version of google's search for "test search"


Expected results:

It should have loaded the desktop version of goole search, i.e. it should have respected the user agent.

NOTE: The User Agent IS working as when I type "google.com" into the address bar, it loads the desktop version of google. It's only searches via the address bar that don't respect the user agent.
(Reporter)

Comment 1

6 years ago
INFO:
Samsung Galaxy Tab 10.1
Firefox Beta (latest updated version from Google Play)
Yes, this is because we force a mobile query through the search-plugin [1].

This might be confusing for some, I suppose.

[1] http://mxr.mozilla.org/mozilla-central/source/mobile/locales/en-US/searchplugins/google.xml

Updated

6 years ago
OS: Linux → Android
Hardware: x86_64 → ARM
(Reporter)

Comment 3

6 years ago
(In reply to Aaron Train [:aaronmt] from comment #2)
> Yes, this is because we force a mobile query through the search-plugin [1].
> 
> This might be confusing for some, I suppose.
> 
> [1]
> http://mxr.mozilla.org/mozilla-central/source/mobile/locales/en-US/
> searchplugins/google.xml

I understand you force it there, but it shouldn't be forced.
(In reply to donrhummy from comment #3) 
> I understand you force it there, but it shouldn't be forced.

bug 761714
(Reporter)

Comment 5

6 years ago
(In reply to Aaron Train [:aaronmt] from comment #4)
> (In reply to donrhummy from comment #3) 
> > I understand you force it there, but it shouldn't be forced.
> 
> bug 761714

Can you explain why that's marked as "won't fix"? This issue is a bug and causes confusion and inconsistency. When a user-agent is set, there is an expectation that this holds for all uses of the browser, not just "some" uses (and especially ones that are not clearly stated to the browser user as diverting from the user-agent).
As far as I know, the rationale led by the mobile dev drivers is that  until they serve us a mobile site, we'll use mobile where we can.
What's the call here?
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
Whiteboard: [wontfix?]
(Reporter)

Comment 8

6 years ago
(In reply to Aaron Train [:aaronmt] from comment #6)
> As far as I know, the rationale led by the mobile dev drivers is that  until
> they serve us a mobile site, we'll use mobile where we can.

I understand that, but that's not a valid reason for applying settings in an inconsistent (and undocumented) manner. If a user has specifically changed the user-agent string, they're expecting that to "drive" the identification of the browser. You can default to mobile but when user-agent is changed, that should be respected - or else pop up a notification/tab letting them know cases where it's not respected.
(In reply to donrhummy from comment #8)
> I understand that, but that's not a valid reason for applying settings in an
> inconsistent (and undocumented) manner. If a user has specifically changed
> the user-agent string, they're expecting that to "drive" the identification
> of the browser.

To be clear, the User Agent setting is always respected -- when you change the User Agent pref with Phony, we send your chosen User-Agent header to Google.  But Google, like many other sites, does not necessarily do anything useful with that header.

Since Google does not use the User-Agent header correctly to direct Firefox users to mobile or desktop sites, the only way we have of giving users this choice is by changing the URL in the search engine plugin.  Perhaps we could include both "Google" and "Google Mobile" search engines by default, and enable/disable them based on form factor.

Phony is currently a simple User-Agent switcher, which means it can't account for all the other ways that sites choose to serve different content.  Phony might be more useful if it also redirected or changed the URLs used for various built-in search engines and bookmarks. That's a feature request for the Phony add-on, and I'll consider adding it especially if someone wants to help out.  (I'm the author of Phony.)
Google made some UA changes recently, so we should no longer need to force the mobile site to be loaded. This should be fixed by bug 783373.
Depends on: 783373
(Reporter)

Comment 11

6 years ago
(In reply to Brian Nicholson (:bnicholson) from comment #10)
> Google made some UA changes recently, so we should no longer need to force
> the mobile site to be loaded. This should be fixed by bug 783373.

What version of firefox is this slated for?
(In reply to donrhummy from comment #11)
> (In reply to Brian Nicholson (:bnicholson) from comment #10)
> > Google made some UA changes recently, so we should no longer need to force
> > the mobile site to be loaded. This should be fixed by bug 783373.
> 
> What version of firefox is this slated for?

17. Watch bug 783373 to see if it also gets uplifted to an earlier version.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 783373
Status: RESOLVED → VERIFIED
(Assignee)

Updated

5 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.