Last Comment Bug 776052 - double click on column headers should not to open selected history item in History window(Ctrl+H)
: double click on column headers should not to open selected history item in Hi...
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: All All
: -- normal (vote)
: seamonkey2.14
Assigned To: neil@parkwaycc.co.uk
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 11:29 PDT by Alice0775 White
Modified: 2012-08-01 09:02 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Proposed patch (2.06 KB, patch)
2012-07-20 13:41 PDT, neil@parkwaycc.co.uk
philip.chee: review+
Details | Diff | Splinter Review

Description Alice0775 White 2012-07-20 11:29:46 PDT
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 SeaMonkey/2.14a1
Build identifier: 20120720003018

In History window(Ctrl+H), if you have some line in the history selected
and double-click on a column headers, --the column sort order
changes twice (as expected), and the history represented by the current
row selection is opened.

Reproducible: Always

Steps to Reproduce:
1. Open History window(Ctrl+H)
2. Expand tree and select history item
3. Click twice quickly on a column header


Actual Results:  
 the selected history is "opened" 

Expected Results:  
 should not open
Comment 1 Philip Chee 2012-07-20 11:53:17 PDT
http://hg.mozilla.org/comm-central/annotate/89103361cbf2/suite/common/history/history.xul#l114

108   <tree id="historyTree"
109         class="placesTree plain"
110         context="placesContext"
111         flex="1" type="places"
112         enableColumnDrag="true"
113         onselect="historyOnSelect();"
114         onkeypress="if (event.keyCode == KeyEvent.DOM_VK_RETURN) PlacesUIUtils.openNodeWithEvent(gHistoryTree.selectedNode, event);"
115         ondblclick="if (event.button == 0) PlacesUIUtils.openNodeWithEvent(gHistoryTree.selectedNode, event);"
116         onclick="if (event.button == 1) PlacesUIUtils.openNodeWithEvent(gHistoryTree.selectedNode, event);">

Hmm. Looks like the click and double-click events bubble up.
Comment 2 Tony Mechelynck [:tonymec] 2012-07-20 12:13:46 PDT
Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Firefox/17.0 SeaMonkey/2.14a1 ID:20120720003018 CSet: ecf5155354d8

Happens not only on Alice's W32-on-W64 but also on this Linux64 build.
Comment 3 neil@parkwaycc.co.uk 2012-07-20 13:41:21 PDT
Created attachment 644450 [details] [diff] [review]
Proposed patch

Unless someone wants to rewrite the history window to share the places front end with bookmarks, as it has its own anti-column-doubleclicking code ;-)
Comment 4 Philip Chee 2012-07-23 04:14:34 PDT
Comment on attachment 644450 [details] [diff] [review]
Proposed patch

Looks good.
Comment 5 neil@parkwaycc.co.uk 2012-07-31 13:30:36 PDT
Pushed comm-central changeset 07aee55a81ca.

Note You need to log in before you can comment on or make changes to this bug.