Last Comment Bug 776108 - Fix undefined behavior due to deleting forward declared pointer
: Fix undefined behavior due to deleting forward declared pointer
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: IndexedDB (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla17
Assigned To: David Zbarsky (:dzbarsky)
:
Mentors:
: 776300 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 14:20 PDT by David Zbarsky (:dzbarsky)
Modified: 2012-07-22 19:04 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (777 bytes, patch)
2012-07-20 14:21 PDT, David Zbarsky (:dzbarsky)
bent.mozilla: review+
Details | Diff | Review

Description David Zbarsky (:dzbarsky) 2012-07-20 14:20:31 PDT

    
Comment 1 David Zbarsky (:dzbarsky) 2012-07-20 14:21:35 PDT
Created attachment 644472 [details] [diff] [review]
Patch
Comment 2 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-07-22 10:27:26 PDT
Comment on attachment 644472 [details] [diff] [review]
Patch

Ha, I found this too, it's in my patch for bug 759427. We can land here or there, I don't care which.
Comment 3 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-07-22 11:04:43 PDT
*** Bug 776300 has been marked as a duplicate of this bug. ***
Comment 4 David Zbarsky (:dzbarsky) 2012-07-22 13:34:04 PDT
Doesn't look like its close to landing, so I'll land here.
Comment 5 David Zbarsky (:dzbarsky) 2012-07-22 13:45:35 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/9964a667659d
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-07-22 19:04:35 PDT
https://hg.mozilla.org/mozilla-central/rev/9964a667659d

Note You need to log in before you can comment on or make changes to this bug.