Keyboard always shows up alpha when app using keyboard is run OOP

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: dhylands, Assigned: vingtetun)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [LOE:M] [WebAPI:P0])

(Reporter)

Description

6 years ago
Tapping in a phone number in the Contacts app, or in the UI Test results in a numeric keypad when the apps are not run OOP, however when the apps are run OOP, you always get an alpha keyboard.

Sometimes you get an alpha keybaord which says "123" in the bottom left, and sometimes it says "ABC" in the bottom left corner.

Also filed in gaia as:
https://github.com/mozilla-b2g/gaia/issues/2656
(Reporter)

Comment 1

6 years ago
All core apps need to run OOP
blocking-basecamp: --- → ?
(Reporter)

Comment 2

6 years ago
I did some investigation and got things tracked down as follows:

Contact app is running from plugin-container.
Both B2G and plugin-container processes wind up calling tryShowIme from b2g/chrome/content/forms.js

The plugin-container process gets passed element: {"type":"tel","choices":null}
The b2g process gets passed element: {"type":"","choices":null}

I saw plugin-container tryShowIme get called 2 times.
I saw b2g tryShowIme get called 6 times.

mozKeyboardReceiveMessage (from b2g/components/MozKeyboard.js) receives a total of 16 messages, 4 of them with detail: detail:{"type":"tel","choices":null} and 12 of them with detail:{"type":"","choices":null}
I think there are two bugs here
 - our focus hacks to determine when to show keyboard must be falling over somehow here

 - we need to scope these IME messages to the frames that got focus
blocking-basecamp: ? → +
Whiteboard: [LOE:M] → [LOE:M] [WebAPI:P0]
Testing that today, this looks fixed. Dave, can you confirm?
(Reporter)

Comment 5

6 years ago
Yep - it looks fixed to me as well.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

6 years ago
Duplicate of this bug: 796409
You need to log in before you can comment on or make changes to this bug.