Firefox freezes when pausing full-screen YouTube video on secondary monitor

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: robert.strauch, Unassigned)

Tracking

Trunk
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 644613 [details]
eventlog.xml

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.57 Safari/536.11

Steps to reproduce:

1. Start Firefox and open a second tab.
2. Drag the new tab to a second display.
3. Watch the following video: http://www.youtube.com/watch?v=uChBJBHoq8E
4. Play video in full-screen mode.
4. Pause the video.
5. Open any website on the first tab on the primary display.


Actual results:

It seems as if the Adobe Flash plugin crashes. Firefox definitely freezes and crashes. Please see attached XML file.


Expected results:

Browsing other websites shall be possible regardless if a YouTube video is playing or being paused.

Comment 1

6 years ago
Are you running Flash 11.3?

Comment 2

6 years ago
I have exactly the same problem. I also have two screens. It does not matter what youtube movie I play. It also does not matter on which screen the youtube movie is playing.

Windows is: Windows 7 x64
Flash version is: FlashPlayerPlugin_11_3_300_268.exe*32
Firefox version is: 13.0.1

Comment 3

6 years ago
@jurrit:
As you're running Flash 11.3, can you test with protected mode disabled in Flash 11.3, please?
Many Flash 11.3 bugs are due to the new protected mode, so it would be great if you could test that.

See the chapter 'last resort' on http://forums.adobe.com/thread/1018071?tstart=0 to disable protected mode.

Comment 4

6 years ago
I followed the instructions in order to disable protected mode. After this Firefox no longer freezes in the situation where the steps to reproduce are followed. 

What does happen after step 5 that the the paused full screen YouTube reverts back from its full screen state to the movie shown on the page.

Comment 5

6 years ago
jurrit, does Firefox crash in your case too? (with protected mode enabled of course)

If yes, could you type about:crashes in location bar and post some crash report URL (with bp-...).
Whiteboard: [flash-11.3]

Comment 6

6 years ago
Firefox never crashed on my PC, it only freezes. I than kill the process FlashPlayerPlugin_11_3_300_268.exe*32 in the task manager. After that Firefox responds again.

Comment 7

6 years ago
I do have some other situation in which flash still crashes. This is when I start a youtube movie and immediately go to the previous page. Here is a crash report of that:

https://crash-stats.mozilla.com/report/index/bp-c85780cc-5ff6-4314-9e0a-eb2392120731

This is with the flash protection mode disabled.

Any help?

Updated

6 years ago
Duplicate of this bug: 780064

Updated

6 years ago
Summary: Firefox freezes when pausing full-screen YouTube video → Firefox freezes when pausing full-screen YouTube video on secondary monitor

Updated

6 years ago
Duplicate of this bug: 778581
I can confirm this one on Windows 7. 
Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/17.0 Firefox/17.0

Only occurs with Protected mode on, so another Flash issue. Also occurs with Flash 11.4
Status: UNCONFIRMED → NEW
Component: Untriaged → Plug-ins
Ever confirmed: true
Product: Firefox → Core
Hardware: x86_64 → All
Version: 14 Branch → Trunk
Is this hang still reproducible with current Flash versions?
Keywords: qawanted
Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20130418 Firefox/23.0

Can't reproduce with Flash 11.7 and latest Nightly on Win7.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
Whiteboard: [flash-11.3]
You need to log in before you can comment on or make changes to this bug.