If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Wikimedia keyboard shortcuts not working

RESOLVED WORKSFORME

Status

()

Firefox
Keyboard Navigation
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Jonty Levine, Unassigned)

Tracking

14 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

I tried to use the keyboard shortcuts on Wikimedia sites (Wikipedia, Wiktionary, Commons, etc). Those shortcuts include ctrl-E, ctrl-P and ctrl S.

Note that these shortcuts are specific to Mac OS. On Windows they would be alt-shift-E, alt-shift-P and alt-shift-S respectively.


Actual results:

Nothing. When I push any CTRL shortcut the mouse cursor disappears until I move it again, but that's it.


Expected results:

Ctrl-E edits a page. Ctrl-P previews a page during editing. And ctrl-S saves a page during editing. Moreover I have tried their equivalents in Firefox 14 on Windows, and they work as expected.
(Reporter)

Updated

5 years ago
Component: Untriaged → Keyboard Navigation
(Reporter)

Comment 1

5 years ago
FWIW I am using Mac OS 10.6.8 on a late 2009 Macbook Pro. I can confirm that the keyboard shortcuts DO work in Firefox 13 on the same computer. Moreover, keyboard shorcuts DON'T work when I disabled all addons in Firefox 14, so it is not caused by an addon.
Jonty: Is this still an issue ?
(Reporter)

Comment 3

5 years ago
No, Wikimedia has changed its keyboard shortcuts on Mac OS X to ones that use CTRL-OPT. They seem to work on Aurora 19.
Thanks Jonty for answering and the bug report.

I will close this report as wfm and sorry that you got no response from us on july but we had no bug triager with OSX in the community ( i have one now ).
You made the bug less discoverable with your bug component change. 
Firefox:keyboard Navigation is only for the keyboard navigation inside Firefox but not for website keyboard shortcuts. Firefox:Untriaged is the right component as start.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.