[IME] When try to move mouse focus to another text field will move the whole pre-determinate string

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: amyy, Assigned: tetsuroy)

Tracking

({intl})

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build: 04-25 Win32 Mtrunk

Steps to reproduce:
1. Launch browser and open a form application which has more than one text 
field.
2. Enable IME and type some CJK characters - not commit it here yet. 
3¡£Move mouse focus to another text field.

Result:
You will see this pre-determinate string was copied to the other text field. 
Note: Similar bug 53025 on Linux and Mac.

Comment 1

18 years ago
Reassign to yokoyama, cc to shanjian.

Is this a regression?
Assignee: nhotta → yokoyama
Keywords: intl
Summary: [IME] When try to move mouse focus to another text field will move the whole pre-determinate string → [IME] When try to move mouse focus to another text field will move the whole pre-determinate string
(Reporter)

Comment 2

18 years ago
WinME-Ja doesn't have this particular problem but has same as in bug 53025.

This problem is on Win2k Simp. Chinese.  Actually there was not that clear in my
previous descriprtion, here is new steps:
1. Launch Browser and open a form that has multiple text fields(e.g. this bug
report application)
2. a. Type some Chinese words - don't commit it here.
   -- You will find there is no underline or highlight around the word
   b. Type Japanese words will get same result as bug 53025
3. Move the mouse focus to another text area.

Result:
There is nothing appear, and you start to hit any key, then the whole 
Chinese string get copied and you press "Backspace" try to delete it, 
but there is nothing get deleted and the Chinese string get copied again.  You
have to disable IME and enable IME again if you still want to get Chinese input.

QA Contact: andreasb → ylong
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 3

17 years ago
I belive this bug is dup of bug 53025. Sorry, it's my bug and
I have to solve gtk issue. Win and Mac seems to be OK, can anyone
the patch (in bug 81356) solve this problem?

Comment 4

17 years ago
This bug has gone, but bug 53025 still exists.

Comment 5

17 years ago
Can't reproduce on 2002-07-17-08-1.0 on Win XP Pro. JA SP1 Beta1
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

17 years ago
Verified not reproducible on latest build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.