FF doesn't block new-style pop-ups that cover side or bottom of page

RESOLVED WONTFIX

Status

()

Firefox
Untriaged
RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: John David Galt, Unassigned)

Tracking

14 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

Viewed web pages that use Wordpress and similar software.


Actual results:

Annoying pop-ups, usually at bottom or right of each page, block reading of text and interfere with the PageUp/PageDown keys performing their proper scrolling function as well.  And right-clicking does nothing, so there's no way to make them go away.


Expected results:

The option for blocking pop-ups should also block these annoying things even though they are not separate windows.
Hello John David,

I just found your 2 years old bug report, but I was not able to reproduce it without additional information. can you maybe give us a URL where we can see such a "popup"?

my first idea is that this is a style part of the page, so there is no way to block it.

thanks for some feedback
Flags: needinfo?(jdg)
(Reporter)

Comment 2

3 years ago
I can no longer find the really bad examples I recall from when I posted this bug, but here is a page where it still happens:

http://www.theatlantic.com/magazine/archive/2014/10/the-society-of-fugitives/379328/

Scroll down two or three screens and a popup saying "Get The Atlantic on Facebook" appears at lower right.  After that you can scroll up or down as much as you like, but that popup stays put.  That's the kind I'm talking about here.
Flags: needinfo?(jdg)
Hello John David,

after checking your example i think we can't solve this.
the "popup" that you are talking about is an CSS and JavaScript part of the page.
so it is nothing that we can identify in the process of loading the page.

sorry to inform you about that. if you have additonal questions to this, please inform me.
if not, i will close this as "WONTFIX" in the next days.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.