Closed Bug 776390 Opened 9 years ago Closed 9 years ago

Unable to share selection

Categories

(Firefox for Android Graveyard :: Text Selection, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox15 verified, firefox16 verified, firefox17 verified)

VERIFIED FIXED
Firefox 17
Tracking Status
firefox15 --- verified
firefox16 --- verified
firefox17 --- verified

People

(Reporter: aaronmt, Assigned: Margaret)

References

Details

Attachments

(1 file)

Long-tap on a selection and select 'Share'. Select Twitter/Messages or anything else and notice there is nothing passed over to the service, e.g, (text message content or Twitter message, etc...).

It looks like the copy operation takes place after a share intent is selected or simply not at all. 

--
Nightly (07/22)
Galaxy Nexus (Android 4.1.1)
Beta on Google Play is unaffected, so this is a new regression
This is probably that race condition issue that mfinkle was worrying about. We should try caching the selected text in case it disappears before the user selects share.
Blocks: 774938
Actually, dumb me, this was a regression caused by bug 773718. Good catch!
Blocks: 773718
No longer blocks: 774938
Attached patch patchSplinter Review
Attachment #644998 - Flags: review?(mbrubeck)
Attachment #644998 - Flags: review?(mbrubeck) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/24bdf8eb8224

The patch for bug 773718 made it into Firefox 16, so I'll request Aurora approval as well.
Target Milestone: --- → Firefox 17
Comment on attachment 644998 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 773718 (currently on aurora, want to uplift to beta)
User impact if declined: can't share or copy text from the context menu
Testing completed (on m-c, etc.): just landed on inbound
Risk to taking this patch (and alternatives if risky): low-risk fix
String or UUID changes made by this patch: n/a
Attachment #644998 - Flags: approval-mozilla-beta?
Attachment #644998 - Flags: approval-mozilla-aurora?
Comment on attachment 644998 [details] [diff] [review]
patch

approved for beta/aurora as part of the dep bugs for native handles for text selection.
Attachment #644998 - Flags: approval-mozilla-beta?
Attachment #644998 - Flags: approval-mozilla-beta+
Attachment #644998 - Flags: approval-mozilla-aurora?
Attachment #644998 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/24bdf8eb8224
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Flags: in-moztrap?(aaron.train)
Aaron - I've created the TCs as I did not find any in MozTrap :https://moztrap.mozilla.org/manage/case/6199/
Flags: in-moztrap?(aaron.train) → in-moztrap+
tracking-fennec: ? → ---
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.