Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Function.toString() is still broken after landing Bug 776389. if script loaded by nested mozIJSSubScriptLoader

VERIFIED FIXED in Firefox 17

Status

()

Core
JavaScript Engine
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Alice0775 White, Assigned: Benjamin)

Tracking

({addon-compat, regression})

17 Branch
mozilla17
x86
Windows 7
addon-compat, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox17- verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Build Identifier:
http://hg.mozilla.org/integration/mozilla-inbound/rev/d12d918df9d6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120722151543

Function.toString() is till broken after landing Bug 776389. if script loaded by nested mozIJSSubScriptLoader

Steps to Reproduce:
1. Start Nightly with new profile
2. Quit browser

3. Create a folder named chrome into the user profile folder
4. Copy 1st(userChrome.js) and 2nd(bugtest.uc.js) attached file into user profile folder\chrome

5. Install userChromeJS v1.5(http://userchromejs.mozdev.org/index.html)
6. Restart browser

Actual Results:
 Only two alert box appear:
  1st: object
  2nd: function

And the following error in the Error Console

Timestamp: 2012/07/23 12:43:49
Error: [Exception... "Failure"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Users/fuku/AppData/Roaming/Mozilla/Firefox/Profiles/5qo5d6ux.ddasda/extensions/userChromeJS@mozdev.org/components/userChrome_js.js -> file:///C:/Users/fuku/AppData/Roaming/Mozilla/Firefox/Profiles/5qo5d6ux.ddasda/chrome/userChrome.js -> file:///C:/Users/fuku/AppData/Roaming/Mozilla/Firefox/Profiles/5qo5d6ux.ddasda/chrome/bugtest.uc.js :: <TOP_LEVEL> :: line 8"  data: no]
Source File: file:///C:/Users/fuku/AppData/Roaming/Mozilla/Firefox/Profiles/5qo5d6ux.ddasda/extensions/userChromeJS@mozdev.org/components/userChrome_js.js
Line: 147

Expected results: 
 Three alert box appear:
  1st: object
  2nd: function
  3rd:
       function (aEvent, aXferData, aDragSession) {
       }
(Reporter)

Comment 1

5 years ago
Created attachment 644825 [details]
please copy this into ProfD\chrome
(Reporter)

Comment 2

5 years ago
Created attachment 644826 [details]
please copy this into ProfD\chrome
(Reporter)

Updated

5 years ago
tracking-firefox17: --- → ?
(Reporter)

Updated

5 years ago
Summary: Function.toString() is till broken after landing Bug 776389. if script loaded by nested mozIJSSubScriptLoader → Function.toString() is still broken after landing Bug 776389. if script loaded by nested mozIJSSubScriptLoader
(Assignee)

Comment 3

5 years ago
Created attachment 644843 [details] [diff] [review]
fix the rightmost arrow
Assignee: general → bpeterson
Attachment #644843 - Flags: review?(bzbarsky)
(Reporter)

Updated

5 years ago
Blocks: 776439

Comment 4

5 years ago
Comment on attachment 644843 [details] [diff] [review]
fix the rightmost arrow

<sigh>

r=me
Attachment #644843 - Flags: review?(bzbarsky) → review+
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/483756fb2e92

Comment 6

5 years ago
https://hg.mozilla.org/mozilla-central/rev/483756fb2e92
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla17
status-firefox17: --- → fixed
tracking-firefox17: ? → -
Keywords: verifyme

Comment 7

5 years ago
Verified as fixed on the 10/16 Nightly, with the steps from comment 0:
Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/19.0 Firefox/19.0

This bug cannot be verified on Firefox 17 beta since userChromeJS can only be installed on Nightly.
Keywords: verifyme
Ioana, this needs to be verified against Firefox 17, not 19. Thank you.
Keywords: verifyme
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #8)
> Ioana, this needs to be verified against Firefox 17, not 19. Thank you.

Oops, sorry. I forgot to notice your comment about userChromeJS compatability. Since this was fixed in Firefox 17 when it was on mozilla-central, I think it's safe to say your verification against Firefox 19 would be valid.

Apologies for my mistake.
Status: RESOLVED → VERIFIED
status-firefox17: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.