Intermittent crash in test_close_on_last_window.xul anim-css-fontsize-1-from-to-px-pct.svg anim-css-strokewidth-1-to-px-pct.svg test_bug300691-2.html [@ js::SourceCompressorThread::compressorThread]

RESOLVED DUPLICATE of bug 779118

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 779118
7 years ago
7 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({crash, intermittent-failure})

Trunk
x86_64
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [js:t], crash signature)

(Reporter)

Description

7 years ago
Rev4 MacOSX Lion 10.7 mozilla-inbound opt test mochitest-other on 2012-07-23 01:17:07 PDT for push fda9279d7031

slave: talos-r4-lion-044

https://tbpl.mozilla.org/php/getParsedLog.php?id=13766247&tree=Mozilla-Inbound

{
28491 INFO TEST-START | chrome://mochitests/content/chrome/toolkit/mozapps/downloads/tests/chrome/test_close_download_manager.xul
28492 INFO TEST-PASS | chrome://mochitests/content/chrome/toolkit/mozapps/downloads/tests/chrome/test_close_download_manager.xul | DMUI closes with ESC key
28493 INFO TEST-PASS | chrome://mochitests/content/chrome/toolkit/mozapps/downloads/tests/chrome/test_close_download_manager.xul | DMUI closes with accel + w
28494 INFO TEST-END | chrome://mochitests/content/chrome/toolkit/mozapps/downloads/tests/chrome/test_close_download_manager.xul | finished in 736ms
28495 INFO TEST-START | chrome://mochitests/content/chrome/toolkit/mozapps/downloads/tests/chrome/test_close_on_last_window.xul
NOTE: child process received `Goodbye', closing down
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/mozapps/downloads/tests/chrome/test_close_on_last_window.xul | Exited with code 1 during test run
INFO | automation.py | Application ran for: 0:06:36.928069
INFO | automation.py | Reading PID log: /var/folders/qd/srwd5f710sj0fcl9z464lkj00000gn/T/tmpZBjVz8pidlog
Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-macosx64/1343028043/firefox-17.0a1.en-US.mac.crashreporter-symbols.zip
PROCESS-CRASH | chrome://mochitests/content/chrome/toolkit/mozapps/downloads/tests/chrome/test_close_on_last_window.xul | application crashed (minidump found)
Crash dump filename: /var/folders/qd/srwd5f710sj0fcl9z464lkj00000gn/T/tmppjiA9n/minidumps/A702CC0C-C837-4A8F-ACAC-94FF38B13686.dmp
Operating system: Mac OS X
                  10.7.2 11C74
CPU: amd64
     family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash address: 0x8

Thread 6 (crashed)
 0  XUL!js::SourceCompressorThread::compressorThread [jsscript.cpp : 1029 + 0x8]
    rbx = 0x07547dc0   r12 = 0x00004e03   r13 = 0x07b04000   r14 = 0x00000000
    r15 = 0x00070e30   rip = 0x02489988   rsp = 0x07b03ed0   rbp = 0x07b03ee0
    Found by: given as instruction pointer in context
 1  libnspr4.dylib!_pt_root [ptthread.c : 156 + 0x6]
    rip = 0x00070efb   rsp = 0x07b03ef0
    Found by: stack scanning
 2  libsystem_c.dylib + 0x4e8be
    rip = 0x8556c8bf   rsp = 0x07b03f20
    Found by: stack scanning
 3  libsystem_c.dylib + 0x51b74
    rip = 0x8556fb75   rsp = 0x07b03f60
    Found by: stack scanning
}
https://tbpl.mozilla.org/php/getParsedLog.php?id=13778351&tree=Mozilla-Inbound
Summary: Intermittent crash in test_close_on_last_window.xul [@ js::SourceCompressorThread::compressorThread] → Intermittent crash in test_close_on_last_window.xul | anim-css-fontsize-1-from-to-px-pct.svg [@ js::SourceCompressorThread::compressorThread]
https://tbpl.mozilla.org/php/getParsedLog.php?id=14214325&tree=Mozilla-Inbound
Blocks: 779118, 780585
Summary: Intermittent crash in test_close_on_last_window.xul | anim-css-fontsize-1-from-to-px-pct.svg [@ js::SourceCompressorThread::compressorThread] → Intermittent crash in test_close_on_last_window.xul anim-css-fontsize-1-from-to-px-pct.svg anim-css-strokewidth-1-to-px-pct.svg [@ js::SourceCompressorThread::compressorThread]
Whiteboard: [orange] → [orange][js:t]
(Reporter)

Updated

7 years ago
Blocks: 795312
(Reporter)

Comment 3

7 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=15805861&tree=Mozilla-Inbound
Summary: Intermittent crash in test_close_on_last_window.xul anim-css-fontsize-1-from-to-px-pct.svg anim-css-strokewidth-1-to-px-pct.svg [@ js::SourceCompressorThread::compressorThread] → Intermittent crash in test_close_on_last_window.xul anim-css-fontsize-1-from-to-px-pct.svg anim-css-strokewidth-1-to-px-pct.svg test_bug300691-2.html [@ js::SourceCompressorThread::compressorThread]
(Reporter)

Updated

7 years ago
Blocks: 800863

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 779118
Whiteboard: [orange][js:t] → [js:t]
You need to log in before you can comment on or make changes to this bug.