Unable to Change Account Preferences

RESOLVED INVALID

Status

()

bugzilla.mozilla.org
Administration
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Gary, Unassigned)

Tracking

Production

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

Attempted to change Account Preferences.


Actual results:

Does not accept my Password (at least what I entered when I created the account). The site only returns the "You did not enter your old password correctly." page.
When Logging In, I can only use Orange "Sign In" <https://login.persona.org/sign_in> button.  The Silver "Log In" button always returns "The username or password you entered is not valid." Page.


Expected results:

I should know what my password is, and be able to change the Account Preferences.
You can reset your password that is stored in BMO by clicking on 'Forgot Password' at the top of the page. It will send you a link via email that will allow you to reset your password. The password you set is the one you will use to make changes to your account in BMO. Although you can login using BrowserID (using the same login name) the passwords are stored differently and you will need to use the BMO specific one to make any account changes.

dkl
Assignee: user-accounts → nobody
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Component: User Accounts → Administration
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Resolution: --- → INVALID
Version: 4.0.6 → Production
(Reporter)

Comment 2

6 years ago
To David Lawrence,

So there are two different passwords; one stored in Persona, and the second in Bugzilla.Mozilla.Org(BMO).  And somehow the Bugzilla.Mozilla.Org(BMO) Account Creation sequence did not properly store the password value which was entered at the time the account was created.

Your advice to change the Bugzilla.Mozilla.Org(BMO) password is itself incomplete, and the Bug Submission rules are very specific on being complete.  The correct instructions are:
On the Bugzilla Home Page, clicking the "Forgot Password" link in the Login Section at the top or bottom of the page just causes the Orange "Sign In" Button, the "Forgot Password" link, and the Remembered Name/Password info to disappear.  An empty 'Login' window appears, along with a silver "Reset Password" Button.  Filling in the 'Login' window with your Account Name (Email Address), and pressing the silver "Reset Password" Button, causes the email to be sent with the required Reset URL.

Possibly, you thought this was a one step process because the Account Name (Email Address) was available in the originally displayed Log In Section with the "Forgot Password" link.  The script could have used this existing information to setup and send the Reset Email in one step, as you suggested, rather than the two steps actually required.
I apologize for mistakenly giving incomplete or inaccurate instructions. But indeed if you enter the account name that you used for BrowserID/Bugzilla login into the forgotten password field, you should get an email with instructions on how to reset your unknown password to something of your choice. Then once you are able to use that correct password, you will be able to change your account preferences. Please let me know if you are unable to get that reset and make the changes you need.

dkl
You need to log in before you can comment on or make changes to this bug.