Last Comment Bug 776700 - Pref off new toSource method
: Pref off new toSource method
Status: RESOLVED FIXED
[MemShrink][qa-]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: mozilla17
Assigned To: general
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on: 776741
Blocks: 776233
  Show dependency treegraph
 
Reported: 2012-07-23 14:14 PDT by David Mandelin [:dmandelin]
Modified: 2012-10-16 16:24 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
hacky turn off (1.50 KB, patch)
2012-07-23 14:14 PDT, :Benjamin Peterson
dmandelin: review+
Details | Diff | Splinter Review

Description David Mandelin [:dmandelin] 2012-07-23 14:14:02 PDT
It's still responsible for at least a 4ms regression on SunSpider. Let's just pref it off so that we can get back to normal, and fix from there.
Comment 1 :Benjamin Peterson 2012-07-23 14:14:53 PDT
Created attachment 645066 [details] [diff] [review]
hacky turn off
Comment 2 David Mandelin [:dmandelin] 2012-07-23 14:21:51 PDT
Comment on attachment 645066 [details] [diff] [review]
hacky turn off

Review of attachment 645066 [details] [diff] [review]:
-----------------------------------------------------------------

Please add a comment next to the hacky bits and land immediately.
Comment 4 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-07-23 15:02:51 PDT
Have you considered using Snappy? http://code.google.com/p/snappy/
Comment 5 :Benjamin Peterson 2012-07-23 15:46:00 PDT
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #4)
> Have you considered using Snappy? http://code.google.com/p/snappy/

The issue is not so much the speed of compresion rather cases when compressing completes before compilation. In the typical case, it's nice to have the better compression ratio of zlib.
Comment 6 :Benjamin Peterson 2012-07-23 15:46:38 PDT
(In reply to Benjamin Peterson from comment #5)
> (In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #4)
> > Have you considered using Snappy? http://code.google.com/p/snappy/
> 
> The issue is not so much the speed of compresion rather cases when
> compressing completes before compilation.

"compilation completes before compression"
Comment 7 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-07-23 17:09:22 PDT
This alone was a 15% regression in memory usage for the entire browser.  Hope you fix this soon!
Comment 8 :Benjamin Peterson 2012-07-23 17:20:06 PDT
Sorry! See bug 776200 for the planned fix.
Comment 9 Ed Morley [:emorley] 2012-07-24 02:59:03 PDT
https://hg.mozilla.org/mozilla-central/rev/d42b966e4262

Note You need to log in before you can comment on or make changes to this bug.