bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[Desktop Build]B2G Desktop Builds: ESC does not exit browser app

RESOLVED WONTFIX

Status

Firefox OS
General
RESOLVED WONTFIX
6 years ago
5 months ago

People

(Reporter: tchung, Unassigned)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Whiteboard: b2g-desktop-builds)

(Reporter)

Description

6 years ago
On the b2g desktop build for Mac, the keyboard ESC button does not exit browser app like other applications.

Repro:
1) install 7-20-2012 desktop OS build on Mac
2) launch b2g build, and open the Browser App
3) Hit ESC on your keyboard
4) Verify it does not exit browser, and instead you need to Quit the app

Expected:
- ESC can get out of the browser

Actual:
- ESC does not kill the app.  i need to force kill it.
We've disabled the back button on the devices.  We should not rely on ESC == back on desktop.  Instead, perhaps we could map ESC to home.
Currently *some* apps respond to ESC, and some only to function + left arrow.

This indicates that the apps are not listening to a consistent event for closing, or that the system is closing apps inconsistently. (I don't know what all the close-initiating inputs are...)

What's the event all apps should listen for? And/or what's the event that should close apps?
> What's the event all apps should listen for? And/or what's the event that should close apps?

My understanding is that we are not targeting devices with a hw back button.  Therefore, all apps should listen to HOME.  Whether they do or don't listen to ESC doesn't affect things on the device, although to mimic our devices, perhaps we should disable ESC on desktop.
blocking-basecamp: ? → -
Should we map ESC to HOME for B2G desktop? That might be a more intuitive way to do it for desktop testers/devs/etc.

Comment 5

6 years ago
On desktop, is the 'Home' key meant to act as a phone's home key? That doesn't appear to work either, at least on my MacBook Pro (where Home is fn+left as there is no native Home key).
Blocks: 776808
I can reproduce this on the windows B2G desktop build too.
Anyone seeing this bug today should make sure you've got the latest Gaia (from the Gaia repo, since the B2G repo doesn't always have the latest Gaia).

We landed a patch to gecko yesterday (#762362) that changes the way the hardware buttons are handled and reported to Gaia.  If you've got the latest b2g desktop client but don't have the latest Gaia, none of the hardware buttons will work.

Note that as part of this change, the Escape key will no longer send a key event to Gaia, so apps that used to respond to Escape will not do so anymore.

The original reporter was reporting a bug about the Back key.  I suspect that comments #5 and #6 are suffering from version skew. 

Brion: fn+left works on my MacBook pro with today's b2g desktop build and the latest gaia, but it didn't work with a 2 day old Gaia and today's b2g desktop build.  

Martijn: would you try again with the very latest Gaia?  

The home key should dismiss an overlay or go to the homescreen, and the escape key should not do anything, ever.
(Reporter)

Comment 8

6 years ago
using whiteboard "b2g-desktop-builds" for ease of tracking
Whiteboard: b2g-desktop-builds

Comment 9

6 years ago
(In reply to David Flanagan [:djf] from comment #7)
> Brion: fn+left works on my MacBook pro with today's b2g desktop build and
> the latest gaia, but it didn't work with a 2 day old Gaia and today's b2g
> desktop build.  
> 
> The home key should dismiss an overlay or go to the homescreen, and the
> escape key should not do anything, ever.

I can confirm with latest Gaia and 2012-07-29 b2g build on my MacBook Pro, I get the same. Escape does nothing (as it apparently should); fn+left (home) now exits applications, as expected. Yay!
Tony,

I don't think there is a bug here. Can you close?
(In reply to David Flanagan [:djf] from comment #7)
> Martijn: would you try again with the very latest Gaia?  

With current b2g build from http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-central/
I overwrote the existing b2g-gaia installation, which I installed from https://groups.google.com/forum/?fromgroups#!topic/mozilla.dev.b2g/-pmLvAHADrw

After that, I wasn't able to click on any icons anymore.

Did I do anything wrong? What is the correct procedure to update a gaia Windows Nightly build? Where can I find gaia on the Mozilla ftp site, btw?
Martijn,

I don't think you did anything wrong. Probably just bad luck that your nightly build was broken.

Gaia is not available by ftp. You have to check it out from github. The most current stuff is always at https://github.com/mozilla-b2g/gaia

I don't know anything about the windows installer that you liked to, though, so I can't comment on that.
I'm still unable to click on any icon to open that particular app. Afaik, I didn't do anything wrong (followed the instructions on how to use b2g desktop).
So I filed bug 781322 for it.
Summary: B2G Desktop Builds: ESC does not exit browser app → [Desktop Build]B2G Desktop Builds: ESC does not exit browser app

Comment 14

5 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.