Closed Bug 776790 Opened 8 years ago Closed 8 years ago

Ignore the app ID sent from content processes when creating windows

Categories

(Core :: DOM: Core & HTML, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 776649

People

(Reporter: cjones, Unassigned)

References

(Blocks 1 open bug)

Details

We use the same ctor message for both parent-created and child-created PBrowser.  But we can't allow content processes to decide which app they're created in, or my browser-tab process could create a popup window that claimed to be the dialer, e.g.
A content process should only be able to create new processes with the same app id.
No longer depends on: 776794
I'm going to incidentally fix this in bug 776649 since I have to modify that code slightly anyway.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 776649
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.