Closed Bug 776803 Opened 8 years ago Closed 6 years ago

Printing a PDF - text is right aligned. If margins are present it also gets cutoff

Categories

(Firefox :: PDF Viewer, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: kc.qubit, Unassigned)

References

(Depends on 1 open bug)

Details

(Whiteboard: [pdfjs-c-feature][pdfjs-d-printing])

Attachments

(1 file)

511.84 KB, application/vnd.ms-xpsdocument
Details
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0
Build ID: 20120723042009

Steps to reproduce:

Selected print preview of a PDF I was viewing using Firefox native pdf reader.

http://www.dbsparks.com/research/html/SNRN02.pdf


Actual results:

All the text is right aligned. If margins are present on left and right the text also gets cutoff


Expected results:

The text should be in the middle of the page like in the pdf and should be adjusted to show properly as per the margins set
Component: Untriaged → PDF Viewer
Attached file Print (.xps)
Yes, the text is cut off.
(For anyone looking for the bug associated with a backout [rev cda1c40da986], the bug number was typoed, the correct bug is bug 776802).
Depends on: 748935
Version: 16 Branch → Trunk
Whiteboard: [pdfjs-c-feature][pdfjs-d-printing]
Can confirm, although printing doesn't really work at all at the moment. Perhaps the print button should be disabled until printing the pdf itself rather than as a webpage is implemented?
Status: UNCONFIRMED → NEW
Ever confirmed: true
I'm not able to reproduce the printed pdf cut off, so it's fixed on my side (working range is near 2012-09-05).

 Kshitij, is it still an issue for you?
Flags: needinfo?(kc_btech-misc)
The error is resolved if 'Shrink to page width' option is enabled in Page Setup dialogue box.
If not, the right margin is cut-off, however, the text doesn't seem to be cut-off anymore.
Flags: needinfo?(kc_btech-misc)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.