If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

videos on What's New page still need to be updated

RESOLVED WONTFIX

Status

www.mozilla.org
General
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: John Slater, Assigned: cmore)

Tracking

unspecified
Future

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=videos p=1, URL)

(Reporter)

Description

5 years ago
This is an addition to bug 763659, but Anthony (quite understandably) asked that we file new bugs for new issues, so that's what I'm doing now.

It's a long story, but the Android videos that were posted on the What's New page last week were low-res versions that shouldn't have been used here. We'd like to use the higher resolution versions instead.

Jaclyn had asked for this in bug 763659, and it was marked fixed in comment #67 of that bug, but no changes have actually shown up on the live site (plus, the French version is still using the placeholder graphic we used initially). Not sure if it was a misunderstanding or some error on the back end, but the bottom line is that we need to do this again.

Those correct versions are posted here:
http://videos.mozilla.org/uploads/marketing/untitled%20folder/

I don't like asking for out of cycle pushes, but we should get this live as soon as possible.

Thanks-
The videos in the "/uploads/marketing/untitled%20folder/" are consistently named except for the French and American variations.

The French version will need to be renamed from:
 17-07-12_firefox_for_android_french_final_640x360.webm
to:
 17-07-12_firefox_for_android_french_final.webm

The American version will need to be renamed from:
 10-07-12_firefox_for_android_american3.webm
to:
 10-07-12_firefox_for_android_american.webm

While we're at it, it might make sense to give these a better folder name than "untitled folder".

They could be moved into:
http://videos-cdn.mozilla.net/serv/marketing/fxforandroid/

Actually, if they were moved into that dir, and renamed with this scheme:
"10-07-12_firefox_for_android_[LOCALE]-640x360 Video Sharing.webm"
we wouldn't need to change the code on the page at all, as these higher quality versions would just replace what's already there.

Who can make this change in the videos.mozilla.org files?

Comment 2

5 years ago
I was the one who uploaded the 10-07-12 videos. My uploading skills aren't very advanced, so I'm not sure how to rename things
(Reporter)

Comment 3

5 years ago
Jaclyn, you'll probably have to rename the files on your desktop and then re-upload.

Comment 4

5 years ago
Hm, I'm trying to rename the folder but it's not allowing me to do so. I also don't have permissions to add files into /fxforandroid folder.

I'll ask IT

Updated

5 years ago
Duplicate of this bug: 776032
Like Steven said, replacing those videos in the fxforandroid directory will automatically change them on the website, as long as they use the same filename scheme.

For high res videos, please don't replace the current videos with higher resolutions. A 150mb video is not suitable for internet consumption (like 17-07-12_firefox_for_android_french_final.webm). This is a 1080p video. If you want to store high-res videos for other media consumptions, upload them with a different filename scheme.

For the french version, we'll need a very quick change in the code to display the video once it is in the right directory.
(Reporter)

Comment 7

5 years ago
Jaclyn, any updates here? We really need to get this fixed...we've had the lo res versions up for way too long.

Comment 8

5 years ago
Hi there!  stepping in to check on updates here.  I realize Jaclyn is no longer on point here so wanted to make sure we get this bug closed soon.  Anything I can help with?  Seems like we're almost there and the remaining step is to rename the files appropriately before they can be uploaded.  Who can help with this? and can we get this done by end of week please? thanks in advance.
(Assignee)

Comment 9

5 years ago
Did anyone file an IT bug to have it uploaded to the CDN with the same URL? We are working on getting access to the video CDN so we don't have to go through IT, but we don't know if that will be allowed.
Target Milestone: --- → Future

Comment 10

5 years ago
(In reply to Chris More [:cmore] from comment #9)
> Did anyone file an IT bug to have it uploaded to the CDN with the same URL?
Not to my knowledge, no. Is that something your team would do or did you need us to do it? I'm not familiar with the process to be honest. Your help is appreciated. 

> We are working on getting access to the video CDN so we don't have to go
> through IT, but we don't know if that will be allowed.

Thanks again.
(Assignee)

Comment 11

5 years ago
Why aren't all of the videos here http://videos.mozilla.org/uploads/marketing/untitled%20folder/ not represented here http://videos-cdn.mozilla.net/serv/marketing/fxforandroid/? This seems complicated to ask IT to upload videos from one place to another place and then rename and overwrite files. There are more files on the CDN than the videos.mozilla.org site.
(Reporter)

Comment 12

5 years ago
I'm not entirely sure to be honest...Jaclyn would possibly know but unfortunately she's no longer at Mozilla.

We want to make things as easy as possible on IT (and everyone, really). What would you recommend as the best way to do that?
(Assignee)

Comment 13

5 years ago
Do we know who has all of the final videos? Is that Rainer? I would like to get the complete batch again, rename them all to what we want and just tell IT to "upload these videos and overwrite". Giving IT complex instructions will lead to possible issues.
(Reporter)

Comment 14

5 years ago
All the final videos are located here:
 
> Those correct versions are posted here:
> http://videos.mozilla.org/uploads/marketing/untitled%20folder/

Comment 15

5 years ago
Happy Monday :) following up on Comment #14, do we have what we need to get these uploaded? would be great to take care of this this week (asap).  Thanks so much.

Updated

5 years ago
Whiteboard: [sp-2012-08-28] u=dev c=videos
(Assignee)

Comment 16

5 years ago
John:

So, we can delete all videos here? http://videos-cdn.mozilla.net/serv/marketing/fxforandroid/ and replace with http://videos.mozilla.org/uploads/marketing/untitled%20folder/?

Why are there so many less videos in the untitled folder as compared to the fxforandroid folder?
(Assignee)

Comment 17

5 years ago
Tara: Since Jfu is not here anymore, any idea who I can talk to about the originals for these videos? 3 of them were not compressed and I need to know where jfu got them from and where are the compressed ones.

Comment 18

5 years ago
This is where I would say "Slater", but his auto-response would point straight back to me :)  Let me look into this a little and see if I can help answer.
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
(Assignee)

Comment 19

5 years ago
(In reply to Tara (musingt) from comment #18)
> This is where I would say "Slater", but his auto-response would point
> straight back to me :)  Let me look into this a little and see if I can help
> answer.

Did you find else about these videos? When will Slater be back?

Comment 20

5 years ago
Sorry wasn't able to find anything.  Will keep looking.  Slater gets back on Monday.
(Reporter)

Comment 21

5 years ago
Hi. I can weigh in on a couple of things here:

- looks like there are fewer videos in the untitled folder vs the fxforandroid folder b/c the untitled one only includes the webm versions. So, unfortunately that means we would need to create the ogv and mp4 versions as well. Chris, do you have a resource who can do that or should I find one? (Jaclyn was in charge of this, and it looks like she didn't take care of this last bit before leaving.)

- which ones aren't compressed? We got the new versions from the animation studio that made the original video. I thought they did them all, but I can cross check against the emails I received from them.

Thanks.
(Assignee)

Comment 22

5 years ago
Hey John: Can you work directly with Rainer on getting the files to him and having him do the compression and conversions? He can he can go over all of them and just needs to know exactly what to do. I just want to tell IT "take all these files and upload them and overwrite all". I also want to make sure everything is named appropriately and it matches what is up on the CDN now.

Thanks

Updated

5 years ago
Whiteboard: [sp-2012-08-28] u=dev c=videos → u=user c=videos p=1

Updated

5 years ago
Assignee: nobody → chrismore.bugzilla
(Assignee)

Comment 23

5 years ago
Jslater: Did you ever make any movement on this? Since I'm not the subject matter expert on these videos and what is what. I need someone to go over all of the videos and collect them in one area and then have Rainer compress the videos.
(Assignee)

Comment 24

5 years ago
John Slater: Is this still relevant given that the What's New pages are going to be changing?
(Reporter)

Comment 25

5 years ago
Sorry for slacking on this. Yes, given the timing you're right that this isn't a priority at this point.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.