Auto-fill address bar adds https:// when i surf to localhost

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
2 years ago

People

(Reporter: vermeulen.thibaut, Unassigned, NeedInfo)

Tracking

14 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 645224 [details]
screenshot.59.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.57 Safari/536.11

Steps to reproduce:

Wanted to surf to my "localhost".



Actual results:

Typed in "localhost" in the url-bar and the auto fill function in FF 14 automatically adds "https://localhost/"


Expected results:

Auto fill function should not apply "https://"
(Reporter)

Updated

6 years ago
Summary: localhost https → Auto-fill address bar adds https:// when i surf to localhost

Comment 1

6 years ago
Any plugins / extensions installed such as "HTTPS Everywhere"?
(Reporter)

Comment 2

6 years ago
Nope, i'm using a switchhost 1.1.0 plugin to edit my windows hostfile live in browser, but i allready disabled the plugin and tried again, with nog succes.

Further addons

- Firebug 1.10
- Dummy lipsum 3.0
- Colorzilla 2.7
- FireFTP 2.0.5
- Gridfox 2.0
- Web Developer 0.7.3
- YSlow 3.1.2
do you remember if you ever tried to visit https://localhost ? since autofill just uses typed urls
try to search for https://localhost in your history
(Reporter)

Comment 5

6 years ago
Yep, in my history i have some "https://localhost/....."-url's

I guess if i delete my history my problem will be solved until i need my https://localhost again, then i will have the same problem.
if you type http://localhost, does it still bring you to the secure version?

Comment 7

5 years ago
Yes, it does even if you explicitly use "http://".

Steps to reproduce:

1.) Visit "https://www.mozilla.com"
2.) Open new tab and enter "http://www.mozilla.com" . Now Firefox automatically adds a "/" at the end of URL. Hit enter key.

Result: Firefox opens https://www.mozilla.com but not http://www.mozilla.com/

If you remove or explicitly type the "/" after "http://www.mozilla.com" it does not redirect to https.

------------------------
User agent: "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
------------------------

Comment 8

3 years ago
This is happening to me too. It's weird. I cannot head to http://localhost at all.

I deleted all my history matching "localhost" and I tried:

- Writing localhost
- Writing localhost:80
- Writing http://localhost
- Writing http://localhost:80
- Same things with trailing /
- Clicking the link in comment 6

Nothing works. The only thing that works is writing a query string, like localhost/web (with or without http://). I'm lucky that my local web resides in that path.

BTW, I shut down my localhost server to make sure it's not sending HTTP Redirects, and it happens the same.

User agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Did you try safe mode? https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Comment 10

3 years ago
(In reply to Marco Bonardo [::mak] from comment #9)
> Did you try safe mode?
> https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-
> mode

Same problem.
If you typed http:// explicitly, I can exclude a locationbar autofill problem, since we would not overwrite what you typed.
Are you sure you didn't setup hsts on the web server?

Comment 12

2 years ago
Do you still have this problem?
Flags: needinfo?(yajo.sk8)
Flags: needinfo?(vermeulen.thibaut)

Comment 13

2 years ago
Not now in FF 40.0.3.
Flags: needinfo?(yajo.sk8)

Comment 14

2 years ago
(In reply to Yajo from comment #13)
> Not now in FF 40.0.3.

Awesome Yajo. Feel free to reopen if you have similar issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.