Closed Bug 776877 Opened 10 years ago Closed 10 years ago

webrtc fails to build with system nspr

Categories

(Core :: WebRTC, defect)

17 Branch
All
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 799975

People

(Reporter: wolfiR, Unassigned)

Details

(Whiteboard: [WebRTC], [blocking-webrtc-])

common_video/jpeg/data_manager.h includes jpeglib.h which itself has
#include "jmorecfg.h"
and in jmorecfg.h there will be included "prtypes.h" from NSPR.

In case of --with-system-nspr the build fails with following error because NSPR system include path is not defined during build.

[  665s] In file included from ../../../../../../dist/include/jmorecfg.h:14:0,
[  665s]                  from ../../../../../../dist/include/jpeglib.h:28,
[  665s]                  from /home/abuild/rpmbuild/BUILD/mozilla/media/webrtc/trunk/src/common_video/../common_video/jpeg/data_manager.h:23,
[  665s]                  from /home/abuild/rpmbuild/BUILD/mozilla/media/webrtc/trunk/src/common_video/jpeg/data_manager.cc:11:
[  665s] ../../../../../../dist/system_wrappers/prtypes.h:3:26: fatal error: prtypes.h: No such file or directory
[  665s] compilation terminated.
QA Contact: jsmith
Whiteboard: [WebRTC], [blocking-webrtc-]
webrtc was disabled for 16.0 but still is on 17.0b.

Will webrtc be enabled for final 17.0? If so this bug should really be fixed since many downstream users usually build against system NSPR.
Version: 16 Branch → 17 Branch
This is fixed on aurora apparently with fix for bug 799975
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 799975
You need to log in before you can comment on or make changes to this bug.