HTML code is displayed in the Edit Review floating box

VERIFIED FIXED in 2012-08-02

Status

Marketplace
Consumer Pages
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Cristian Boldan, Assigned: cvan)

Tracking

2012-08-02
Points:
---

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 645272 [details]
edit review code

Steps to reproduce:
1. Load reviews page for an app (ex. https://marketplace-dev.allizom.org/app/in-app-payment-tester/reviews/ )
2. Submit a review
3. Add a reply to your review
4. Click the "Edit" link from your first added review

Expected results:
The text box displays the content of your first review.

Actual results:
The following code "<a href="#" class="view-reply">1 reply</a>" is displayed in the text box.

Notes/Issues:
Verified on FF17 (Win7). Issue is only reproducing when logged in with the admin account. Reply feature is not available for other accounts.
Also, when the "1 reply" link is clicked, all the replies, including other comments, are closed/opened. Please let me know if I should log another bug for this issue.
Attaching screenshot for this issue.
(Assignee)

Comment 1

5 years ago
There's also weirdly a middot shown where the "Report" link should be (but since it's your own review we aren't showing it): http://cl.ly/image/0J012K003H3c

Not really related to this bug, but that's gross.
(Assignee)

Updated

5 years ago
Assignee: nobody → ngoke
OS: Windows 7 → All
Hardware: x86_64 → All
Target Milestone: --- → 2012-07-26

Comment 2

5 years ago
Created attachment 645940 [details]
screenshot

This also happens with developer replies. Notice that <br> tags are visible
(Assignee)

Updated

5 years ago
Assignee: ngoke → nobody
Priority: -- → P1
Target Milestone: 2012-07-26 → 2012-08-02
(Assignee)

Comment 3

5 years ago
https://github.com/mozilla/zamboni/commit/c6acb54
Assignee: nobody → cvan
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

5 years ago
Verified as fixed in https://marketplace-dev.allizom.org/en-US/ on FF17 (Win 7)
Attaching postfix screenshot.
Closing bug.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

5 years ago
Created attachment 647930 [details]
postfix edit review
You need to log in before you can comment on or make changes to this bug.