Reader Mode: Toolbar icons are low resolution (scaled) on XHDPI devices

RESOLVED DUPLICATE of bug 779527

Status

()

Firefox for Android
Reader View
RESOLVED DUPLICATE of bug 779527
6 years ago
4 years ago

People

(Reporter: aaronmt, Assigned: lucasr)

Tracking

({polish, uiwanted})

Trunk
ARM
Android
polish, uiwanted
Points:
---

Firefox Tracking Flags

(firefox16 affected, firefox17 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 645279 [details]
Nightly (07/24) Screenshot

On my Galaxy Nexus (Android 4.1.1) taking a gander at the reader mode toolbar icons one would see that the icons are fuzzy and not as sharp in comparison to other icons found throughout the device and operating system and even the browser (the tab button [+] is sharp).
(Reporter)

Updated

6 years ago
Keywords: uiwanted
(Assignee)

Comment 1

6 years ago
(In reply to Aaron Train [:aaronmt] from comment #0)
> Created attachment 645279 [details]
> Nightly (07/24) Screenshot
> 
> On my Galaxy Nexus (Android 4.1.1) taking a gander at the reader mode
> toolbar icons one would see that the icons are fuzzy and not as sharp in
> comparison to other icons found throughout the device and operating system
> and even the browser (the tab button [+] is sharp).

Is this Jelly Bean specific? Last time I checked this was working fine...
We currently don't have resolution specific images in Gecko side. So, the images are just scaled, and doesn't hold up to XHDPI resolution.

This sort of bug can be seen in about: page background mismatch with url-bar, the dividers are too tiny and similar sorts.
(Reporter)

Comment 3

6 years ago
So the only prescription is, more images.
(Reporter)

Updated

6 years ago
Summary: Reader Mode: Toolbar icons are too low res → Reader Mode: Toolbar icons are low resolution (scaled) on XHDPI devices
(Assignee)

Comment 4

6 years ago
(In reply to Sriram Ramasubramanian [:sriram] from comment #2)
> We currently don't have resolution specific images in Gecko side. So, the
> images are just scaled, and doesn't hold up to XHDPI resolution.

The Reader UI has proper media queries and provide assets for all screen densities. This is probably a bug in the CSS.
 
> This sort of bug can be seen in about: page background mismatch with
> url-bar, the dividers are too tiny and similar sorts.

Reader UI has proper density support. Yes, the other about: pages have this issue, not reader.
(Assignee)

Comment 5

6 years ago
Just found out that the pixel ratio coming from Gecko is just wrong on Galaxy Nexus. It's supposed be 2.0 but I'm getting 1.0. Because of things, a media query like "(-moz-device-pixel-ratio: 2.0) is just not matching on the device.
(Assignee)

Comment 6

6 years ago
Created attachment 647179 [details] [diff] [review]
Use correct media query to match hdpi and xhdpi devices

Here's the patch that is supposed to fix the bug but is not because the pixel ratio coming from Gecko is just wrong. Any idea of what might be going on here?
Attachment #647179 - Flags: review?(mark.finkle)
(Assignee)

Comment 7

5 years ago
Turns out to be a regression bug in Gecko (see bug 779527). The reader CSS doesn't really need to be changed.
Depends on: 779527
(Assignee)

Updated

5 years ago
Assignee: nobody → lucasr.at.mozilla
Can we close this bug then?
(Assignee)

Comment 9

5 years ago
(In reply to Mark Finkle (:mfinkle) from comment #8)
> Can we close this bug then?

I'd prefer to wait until bug 779527 is fixed before closing this one, just in case.
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 779527
Attachment #647179 - Flags: review?(mark.finkle)
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.