Last Comment Bug 776925 - Quick Filter Status in View Menu desyncs when the Quick Filter toolbar button is removed
: Quick Filter Status in View Menu desyncs when the Quick Filter toolbar button...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Toolbars and Tabs (show other bugs)
: unspecified
: x86 Windows XP
: -- minor (vote)
: Thunderbird 18.0
Assigned To: Jim Porter (:squib)
:
Mentors:
: 787058 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 07:56 PDT by David E. Ross
Modified: 2012-10-10 21:14 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
localstore.rdf file that causes the problem (8.02 KB, text/plain)
2012-09-03 15:25 PDT, David E. Ross
no flags Details
Fix this (6.32 KB, patch)
2012-09-03 17:05 PDT, Jim Porter (:squib)
bugmail: review+
Details | Diff | Splinter Review

Description David E. Ross 2012-07-24 07:56:41 PDT
Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20120713 Thunderbird/14.0
View > Layout > Wide View
Quick Filter toolbar NOT displayed (my default).  

Dismissing the Quick Filter toolbar by using the ESC key fails to remove the checkmark for that toolbar in the View menu.  

1.  In the menu bar, launch the Quick Filter toolbar by selecting [View > Toolbars > Quick Filter Bar].  

2.  Dismiss the Quick Filter toolbar by using the ESC key.  The Quick Filter toolbar closes.  

3.  In the menu bar, select [View > Toolbars].  There is still a checkmark next to Quick Filter Bar.  

4.  In the menu bar, again launch the Quick Filter toolbar by selecting [View > Toolbars > Quick Filter Bar].  

5.  In the menu bar, select [View > Toolbars].  There is no checkmark next to Quick Filter Bar even though the toolbar is present.  

This lack of synchronization between the reality of the toolbar and the status shown in the View menu persists as the toolbar's presence is toggled.  

If the toolbar was present when terminating Thunderbird while reality and the View menu were indeed synchronized, synchronization is lost when launching Thunderbird.  

1.  In the menu bar, launch the Quick Filter toolbar by selecting [View > Toolbars > Quick Filter Bar].  

2.  Terminate Thunderbird.  

3.  Launch Thunderbird.  The Quick Filter toolbar is present.  

4. In the menu bar, select [View > Toolbars].  There is no checkmark next to Quick Filter Bar.  

ONLY if the toolbar was dismissed before terminating Thunderbird, launching Thunderbird restores the synchronization of reality with the View menu.
Comment 1 Jim Porter (:squib) 2012-09-03 02:14:08 PDT
WFM on 15.0
Comment 2 David E. Ross 2012-09-03 10:07:47 PDT
Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20120824 Thunderbird/15.0
Default 15.0 theme
NO enabled plugins

Running Thunderbird in Safe Mode, the problem did not occur.  I then tried selectively disabling my four extensions -- not in Safe Mode -- to see which one might cause the problem.  With ALL extensions disabled, however, the problem still appeared.  

Since the only difference between Safe Mode and disabling all extensions is that Safe Mode also disables the theme, I must conclude that the problem lies within the Default 15.0 theme (something that was carried forward from the Default 14.0 theme and possibly prior themes).  I cannot find a way outside of Safe Mode to disable the current theme in order to confirm this.  

Still a problem.  Does NOT work for me.
Comment 3 Jim Porter (:squib) 2012-09-03 11:07:10 PDT
(In reply to David E. Ross from comment #2)
> Since the only difference between Safe Mode and disabling all extensions is
> that Safe Mode also disables the theme

That's not actually what happens when you start safe mode. If it did, you'd end up with no UI (or at least, a *completely* broken UI).

However, there is another important difference in safe mode: all your UI customizations are reset (notably localstore.rdf). Something in there is probably invalid and causing errors.
Comment 4 David E. Ross 2012-09-03 15:25:56 PDT
Created attachment 657925 [details]
localstore.rdf file that causes the problem

With Thunderbird terminated, I located localstore.rdf in the profile and renamed it x-localstore.rdf-x.  When I then launched Thunderbird, it created a new localstore.rdf; and the problem went away.  

However, I do not like the default set of buttons; so I customized the buttons using the standard user interface (right-click and select Customize on the various Thunderbird tool bars, drag-and-drop buttons to add or remove them).  The problem reappeared.  

Yes, the problem lies within localstore.rdf or in how Thunderbird uses that file.  However, I think my customization was valid since I only used the end-user interface.  I am attaching a copy of my localstore.rdf file for others to diagnose this problem.
Comment 5 Jim Porter (:squib) 2012-09-03 16:12:07 PDT
Updating bug title to reflect what's actually happening here.
Comment 6 Jim Porter (:squib) 2012-09-03 17:05:32 PDT
Created attachment 657953 [details] [diff] [review]
Fix this

This fixes the issue by enabling/disabling the commands, rather than the buttons, and by having the checked attribute of the toolbar button observe the menuitem, rather than vice versa. That way, we properly update the check mark even when the toolbar is removed.

All the QFB tests pass locally with this patch.
Comment 7 Jim Porter (:squib) 2012-09-06 19:22:52 PDT
Checked in: http://hg.mozilla.org/comm-central/rev/6ed66e622bb0
Comment 8 Ludovic Hirlimann [:Usul] 2012-09-26 07:12:02 PDT
*** Bug 787058 has been marked as a duplicate of this bug. ***
Comment 9 David E. Ross 2012-10-10 20:52:42 PDT
In which version of Thunderbird is this being fixed?  It is still a problem in 
    Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20121005 Thunderbird/16.0
Comment 10 Jim Porter (:squib) 2012-10-10 21:14:17 PDT
18, I think.

Note You need to log in before you can comment on or make changes to this bug.