set hour for daily matviews crontabber job

RESOLVED FIXED in 17

Status

Socorro
Infra
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: rhelmer, Assigned: rhelmer)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

6 years ago
re: bug 775603 comment 1, this job is time sensitive and should specify the hour to start.
(Assignee)

Comment 1

6 years ago
peterbe - r? https://github.com/mozilla/socorro/pull/725

I made everything start at 2 AM like the old system (since jobs that are not dependent should be able to run in parallel) - however the problem is that we haven't actually tested running these things in parallel and that it doesn't cause unexpected problems (overloading the database for example although that feels unlikely to me).

The old system ran everything in serial since it was just a single script.

I'm not sure we can adequately test this in staging, both due to bug 771218 and also because the overall volume on staging is so low.

Comment 2

6 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/e2cfd70f002c2502b8810ab52fb7ce971182686c
Merge pull request #725 from rhelmer/bug777010-specify-matview-start-hour

bug 775603 - specify start times for time-sensitive jobs
Perhaps I misinterpret you but...
In crontabber all jobs are done synchronously. Jobs are never run in parallel.
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.