Last Comment Bug 777068 - Consolidate some 3rd party Python packages to /python
: Consolidate some 3rd party Python packages to /python
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: Gregory Szorc [:gps]
:
Mentors:
Depends on: 754469 775243 777465
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 14:07 PDT by Gregory Szorc [:gps]
Modified: 2012-07-27 09:00 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Move blessings, v1 (2.18 KB, patch)
2012-07-24 14:12 PDT, Gregory Szorc [:gps]
mh+mozilla: review+
Details | Diff | Splinter Review
Move virtualenv, v1 (7.71 KB, patch)
2012-07-25 12:20 PDT, Gregory Szorc [:gps]
mh+mozilla: review+
Details | Diff | Splinter Review
Move simplejson, v1 (14.63 KB, patch)
2012-07-25 12:21 PDT, Gregory Szorc [:gps]
mh+mozilla: review+
Details | Diff | Splinter Review

Description Gregory Szorc [:gps] 2012-07-24 14:07:05 PDT
We now have a /python top-level directory per bug 775243!

We can seed it with some 3rd party Python packages checked into the tree. Patches forthcoming.
Comment 1 Gregory Szorc [:gps] 2012-07-24 14:12:09 PDT
Created attachment 645487 [details] [diff] [review]
Move blessings, v1

Move blessings from build/pylib/blessings to python/blessings.

Splinter probably won't work because I used |hg mv| and the patch has renames.
Comment 2 Gregory Szorc [:gps] 2012-07-24 14:17:14 PDT
I'm pretty sure we can move virtualenv and simplejson from other-licenses/ since I believe they have an MPL-compatible license. But, I'm not a lawyer.

Gerv: are the following licenses MPL-compatible?

https://hg.mozilla.org/mozilla-central/file/34b14c220817/other-licenses/virtualenv/LICENSE.txt
https://hg.mozilla.org/mozilla-central/file/34b14c220817/other-licenses/simplejson-2.1.1/LICENSE.txt
Comment 3 Mike Hommey [:glandium] 2012-07-24 23:48:51 PDT
Comment on attachment 645487 [details] [diff] [review]
Move blessings, v1

Review of attachment 645487 [details] [diff] [review]:
-----------------------------------------------------------------

::: build/virtualenv/packages.txt
@@ +5,5 @@
>  setup.py:testing/mozbase/mozlog:develop
>  setup.py:testing/mozbase/mozprocess:develop
>  setup.py:testing/mozbase/mozprofile:develop
>  setup.py:testing/mozbase/mozrunner:develop
> +setup.py:python/blessings:develop

You need a refresh after bug 776046
Comment 4 Gregory Szorc [:gps] 2012-07-25 00:01:40 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/b61beb4ae24f

Leaving open to deal with virtualenv and simplejson (possibly).
Comment 5 Ed Morley [:emorley] 2012-07-25 08:09:28 PDT
https://hg.mozilla.org/mozilla-central/rev/b61beb4ae24f
Comment 6 Gervase Markham [:gerv] 2012-07-25 11:47:52 PDT
(In reply to Gregory Szorc [:gps] from comment #2)
> Gerv: are the following licenses MPL-compatible?

Yes. Please do move these packages out of other-licenses. :-)

Gerv
Comment 7 Gregory Szorc [:gps] 2012-07-25 12:20:16 PDT
Created attachment 645850 [details] [diff] [review]
Move virtualenv, v1

Moves virtualenv to python/
Comment 8 Gregory Szorc [:gps] 2012-07-25 12:21:11 PDT
Created attachment 645852 [details] [diff] [review]
Move simplejson, v1

Moves simplejson to python/.

These may break without clobber because I discovered that the dependencies for virtualenv regeneration in client.mk aren't correct.

Note You need to log in before you can comment on or make changes to this bug.