Last Comment Bug 777094 - Qt fail to compile due to wrong GL includes order
: Qt fail to compile due to wrong GL includes order
Status: RESOLVED FIXED
: regression
Product: Core Graveyard
Classification: Graveyard
Component: Widget: Qt (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla17
Assigned To: Oleg Romashin (:romaxa)
:
Mentors:
Depends on:
Blocks: 771350
  Show dependency treegraph
 
Reported: 2012-07-24 14:56 PDT by Oleg Romashin (:romaxa)
Modified: 2016-07-11 21:54 PDT (History)
4 users (show)
ryanvm: in‑testsuite-
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Put QGL include before GLDefs.h (1.49 KB, patch)
2012-07-24 15:04 PDT, Oleg Romashin (:romaxa)
dougt: review+
Details | Diff | Splinter Review
GLIfdef fix, to avoid breakage in future (810 bytes, patch)
2012-07-24 15:15 PDT, Oleg Romashin (:romaxa)
no flags Details | Diff | Splinter Review

Description Oleg Romashin (:romaxa) 2012-07-24 14:56:15 PDT
Qt build got busted in inbound after some recent fix which bring GLDefs.h include into nsWindow.h:
https://tbpl.mozilla.org/php/getParsedLog.php?id=13786738&tree=Mozilla-Inbound#error0
That broke qgl.h include because __gl_h_ got defined disabled include for GL/gl.h and GLDefs don't have standard non-local GL defines 

probably bug 776217, not sure
Comment 1 Oleg Romashin (:romaxa) 2012-07-24 15:04:19 PDT
Created attachment 645523 [details] [diff] [review]
Put QGL include before GLDefs.h

Tested on maemo and desktop qt build
Comment 2 Doug Turner (:dougt) 2012-07-24 15:08:39 PDT
Comment on attachment 645523 [details] [diff] [review]
Put QGL include before GLDefs.h

rs+
Comment 3 Oleg Romashin (:romaxa) 2012-07-24 15:10:03 PDT
Actually this change broke compilation
https://hg.mozilla.org/integration/mozilla-inbound/rev/8bd1560c17a3#l8.12
Comment 4 Oleg Romashin (:romaxa) 2012-07-24 15:15:02 PDT
Created attachment 645532 [details] [diff] [review]
GLIfdef fix, to avoid breakage in future

GLDefs version
Comment 5 Oleg Romashin (:romaxa) 2012-07-24 15:17:15 PDT
Comment on attachment 645532 [details] [diff] [review]
GLIfdef fix, to avoid breakage in future

oh, this will not work. and break ipdl compilation
Comment 6 Mike Hommey [:glandium] 2012-07-24 15:22:15 PDT
The breakage started with bug 771350
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-07-24 18:39:17 PDT
Please remove the checkin-needed when you land your patches.
Comment 9 Oleg Romashin (:romaxa) 2012-07-24 20:03:42 PDT
oh, sorry forgot about that while was fighting with closed tree behaviour
Comment 10 Ed Morley [:emorley] 2012-07-25 08:10:42 PDT
https://hg.mozilla.org/mozilla-central/rev/ef6fac0c8330

Note You need to log in before you can comment on or make changes to this bug.