Closed Bug 777183 Opened 9 years ago Closed 8 years ago

IonMonkey: OOM Testing: Crash [@ js::ion::IonCode::raw]

Categories

(Core :: JavaScript Engine, defect)

Other Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 790921

People

(Reporter: decoder, Unassigned)

References

Details

(Keywords: crash, testcase, Whiteboard: [ion:p2:fx18])

Crash Data

The following command crashes on ionmonkey revision b82fb4d04f60 (dbg build):

js  -e 'const libdir = "js/src/jit-test/lib/";' -A 15209 -f js/src/jit-test/tests/v8-v5/check-richards.js
(In reply to Christian Holler (:decoder) from comment #0)
> The following command crashes on ionmonkey revision b82fb4d04f60 (dbg build):
> 
> js  -e 'const libdir = "js/src/jit-test/lib/";' -A 15209 -f
> js/src/jit-test/tests/v8-v5/check-richards.js

I can't reproduce this one either :( what does the stack look like?
NULL check is somewhat mishandled in MacroAssembler::callPreBarrier, we set the OOM flag but do not escape.
Whiteboard: [ion:p2:fx18]
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 790921
You need to log in before you can comment on or make changes to this bug.