If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Tutorial page's core library documentation pages link is 404 not found

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Add-on Builder
--
major
RESOLVED WONTFIX
5 years ago
8 months ago

People

(Reporter: mwrenton, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

Clicked the link
 core library documentation
in the page
 https://builder.addons.mozilla.org/tutorial/
whose link value is
 https://builder.addons.mozilla.org/docs/packages/addon-kit/addon-kit.html


Actual results:

404 Not Found
on
 https://addons.mozilla.org/en-US/developers/docs/sdk/latest/packages/addon-kit/packages/addon-kit/addon-kit.html


Expected results:

redirect to
 https://addons.mozilla.org/en-US/developers/docs/sdk/latest/packages/addon-kit/
https://addons.mozilla.org/en-US/developers/docs/sdk/latest/packages/addon-kit/packages/addon-kit/addon-kit.html
error code: 404 (not found), linked from page(s):
	https://builder.addons.mozilla.org/docs/packages/addon-kit/addon-kit.html

https://addons.mozilla.org/en-US/developers/docs/sdk/latest/packages/addon-kit/packages/addon-kit/context-menu.html
error code: 404 (not found), linked from page(s):
	https://builder.addons.mozilla.org/docs/packages/addon-kit/context-menu.html

https://addons.mozilla.org/en-US/developers/docs/sdk/latest/packages/addon-kit/packages/addon-kit/simple-storage.html
error code: 404 (not found), linked from page(s):
	https://builder.addons.mozilla.org/docs/packages/addon-kit/simple-storage.html

https://addons.mozilla.org/en-US/developers/docs/sdk/latest/packages/addon-kit/packages/addon-kit/widget.html
error code: 404 (not found), linked from page(s):
	https://builder.addons.mozilla.org/docs/packages/addon-kit/widget.html
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
Assignee: nobody → ejpbruel
QA Contact: ejpbruel
Created attachment 694564 [details]
Fix broken links

This should be the correct links.

According to KWierso, there is still some redirect problem going on, but I can't reproduce it. Perhaps clouserw could look into it?
Attachment #694564 - Flags: review?(zaloon)
Wil, would you be a/the person to talk to for why the URL is getting screwed up when redirecting from BAMO to AMO?

With this pull request landed, if you scroll to the bottom of https://builder-addons-dev.allizom.org/tutorial/ and click the "core library documentation" link, it says to load https://builder-addons-dev.allizom.org/docs/sdk/latest/ but Web Console says it loads https://jetpack.mozillalabs.com/sdk/latest/docs/sdk/latest/ (with a 302 response) and then finally ends up with a 404 error at https://addons.mozilla.org/en-US/developers/docs/sdk/latest/sdk/latest/


Interestingly, if you try loading a similar link, but from the production site <https://builder.addons.mozilla.org/docs/sdk/latest/>, you get a 301 redirect to https://addons.mozilla.org/en-US/developers/docs/sdk/latest/packages/addon-kit/sdk/latest/ which is the 404 error.

So there's some differences in how dev and prod are handling links, but neither works correctly with the SDK's documentation structure...

Updated

5 years ago
Duplicate of this bug: 824213
Are these redirects controlled in the vhost or the code?  Have the redirects ever worked?  If they exist in the vhost we'll need to talk to IT (jason or jeremy).
I couldn't find any instances of parts of those URLs using grep on Flightdeck's repository, so I'd assume it's not part of the code.
The docs link on builder.addons.mozilla.org is broken too.

Updated

4 years ago
Assignee: ejpbruel → nobody
QA Contact: ejpbruel

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
Why was this closed?
Add-on Builder is now in read-only mode - its only days until shut down.
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard

Updated

8 months ago
Attachment #694564 - Flags: review?(pzalewa) → review?
You need to log in before you can comment on or make changes to this bug.