Last Comment Bug 777274 - The content of History and Top Sites sections is not cleared when clearing private data
: The content of History and Top Sites sections is not cleared when clearing pr...
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 15 Branch
: ARM Android
: -- normal (vote)
: ---
Assigned To: Brian Nicholson (:bnicholson)
:
Mentors:
: 778394 779186 779226 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 02:48 PDT by Paul Feher
Modified: 2013-12-10 10:01 PST (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified


Attachments
Fix check to clear Java-side history (1.17 KB, patch)
2012-07-29 23:48 PDT, Brian Nicholson (:bnicholson)
mark.finkle: review+
akeybl: approval‑mozilla‑beta+
Details | Diff | Review

Description Paul Feher 2012-07-25 02:48:17 PDT
Firefox Mobile Native 15.0b2 build1 (2012-07-24)
Device: HTC Desire Z(Android 2.3.3)/HTC Desire (Android 2.2)

Steps to reproduce:
1. Load a few pages.
2. Clear private data. Make sure "Browsing&Download History" is selected.
4. Open the Awesome-bar and check the History and Top Sites sections.

Expected results:
The History and Top Sites sections are empty.

Actual results:
The records from History and Top Sites sections are still present.
Comment 1 Brian Nicholson (:bnicholson) 2012-07-25 10:14:10 PDT
(In reply to Paul Feher from comment #0)
> Firefox Mobile Native 15.0b2 build1 (2012-07-24)
> Device: HTC Desire Z(Android 2.3.3)/HTC Desire (Android 2.2)
> 
> Steps to reproduce:
> 1. Load a few pages.
> 2. Clear private data. Make sure "Browsing&Download History" is selected.
> 4. Open the Awesome-bar and check the History and Top Sites sections.
> 
> Expected results:
> The History and Top Sites sections are empty.
> 
> Actual results:
> The records from History and Top Sites sections are still present.

Do you have Sync set up? Right now, I think clearing private data only clears local data.
Comment 2 Paul Feher 2012-07-25 23:47:37 PDT
(In reply to Brian Nicholson (:bnicholson) from comment #1)
> (In reply to Paul Feher from comment #0)
> > Firefox Mobile Native 15.0b2 build1 (2012-07-24)
> > Device: HTC Desire Z(Android 2.3.3)/HTC Desire (Android 2.2)
> > 
> > Steps to reproduce:
> > 1. Load a few pages.
> > 2. Clear private data. Make sure "Browsing&Download History" is selected.
> > 4. Open the Awesome-bar and check the History and Top Sites sections.
> > 
> > Expected results:
> > The History and Top Sites sections are empty.
> > 
> > Actual results:
> > The records from History and Top Sites sections are still present.
> 
> Do you have Sync set up? Right now, I think clearing private data only
> clears local data.

This happens with a clean profile without any sync account being set up. The local data is not cleared.
Comment 3 Brian Nicholson (:bnicholson) 2012-07-29 23:37:53 PDT
*** Bug 778394 has been marked as a duplicate of this bug. ***
Comment 4 Brian Nicholson (:bnicholson) 2012-07-29 23:48:47 PDT
Created attachment 647081 [details] [diff] [review]
Fix check to clear Java-side history

Bug 775042 changed the "history" key to "history_downloads". PrivateDataPreference.java wasn't updated for this change, breaking this feature. We didn't need this patch in 16+ because bug 771036 changed the "Sanitize:ClearHistory" message to be fired from JS instead.

So for beta, our options are to either land this or bug 771036. Bug 771036 seems like a low risk patch; it might be nice to land that so add-ons can also be fixed.
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2012-07-30 07:39:47 PDT
This patch is drop dead simple, so let's use it for Fx15. Please nom for uplift.
Comment 6 Brian Nicholson (:bnicholson) 2012-07-30 11:21:14 PDT
Comment on attachment 647081 [details] [diff] [review]
Fix check to clear Java-side history

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 775042
User impact if declined: history cannot be cleared
Testing completed (on m-c, etc.): tried locally and it works
Risk to taking this patch (and alternatives if risky): low risk, beta only
String or UUID changes made by this patch: none
Comment 7 Brian Nicholson (:bnicholson) 2012-07-30 12:52:57 PDT
http://hg.mozilla.org/releases/mozilla-beta/rev/5d967bdec4a3
Comment 8 Aaron Train [:aaronmt] 2012-07-31 10:29:26 PDT
*** Bug 779186 has been marked as a duplicate of this bug. ***
Comment 9 Aaron Train [:aaronmt] 2012-07-31 11:24:20 PDT
*** Bug 779226 has been marked as a duplicate of this bug. ***
Comment 10 Xiao Meng Wei :xwei 2012-08-01 10:36:34 PDT
Verified on Nexus 7 , JB4.1.1, Fennec 15 beta 3.
Comment 11 Markus Popp 2012-08-01 11:43:49 PDT
Also works again on SGS2 with Android 4.0.3.

Note You need to log in before you can comment on or make changes to this bug.