Last Comment Bug 777303 - JavaScript strict warning: chrome://messenger/content/tabmail.xml, line 1106: reference to undefined property tab.thinking
: JavaScript strict warning: chrome://messenger/content/tabmail.xml, line 1106:...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Toolbars and Tabs (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: Thunderbird 17.0
Assigned To: Nobody; OK to take it and work on it
: instant-messaging
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 04:38 PDT by Florian Quèze [:florian] [:flo]
Modified: 2012-08-07 11:12 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (1.17 KB, patch)
2012-07-25 04:38 PDT, Florian Quèze [:florian] [:flo]
mconley: review+
Details | Diff | Splinter Review

Description Florian Quèze [:florian] [:flo] 2012-07-25 04:38:55 PDT
Created attachment 645707 [details] [diff] [review]
Patch

Warning: ReferenceError: reference to undefined property tab.thinking
Source File: chrome://messenger/content/tabmail.xml
Line: 1106

I've wasted enough time looking at this warning and wondering if it was caused by my chat tab missing a JS property, or my changes breaking something in the gloda facet view tab that I think it's worth fixing. Hopefully it will save time for others too :).

Steps to reproduce:
- Open Thunderbird, the 3 pane view is selected by default.
- Open a second tab.
- Select the 3 pane tab.

The warning appears when selecting the 3 pane tab for the first time (not when it was automatically selected at startup).


The cause is simply that the thinking property is never initialized for the first tab: http://hg.mozilla.org/comm-central/annotate/3f7c3f228397/mail/base/content/tabmail.xml#l413
Here's the initialization for the other tabs: http://hg.mozilla.org/comm-central/annotate/3f7c3f228397/mail/base/content/tabmail.xml#l470

Trivial patch attached.
Comment 1 Mike Conley (:mconley) - (Needinfo me!) 2012-08-02 10:26:31 PDT
Comment on attachment 645707 [details] [diff] [review]
Patch

I like it. Thanks Florian.
Comment 2 Florian Quèze [:florian] [:flo] 2012-08-07 11:12:18 PDT
https://hg.mozilla.org/comm-central/rev/d691b48ea0f6

Note You need to log in before you can comment on or make changes to this bug.