Last Comment Bug 777397 - YSlow possibly causing frequent Firefox hangs
: YSlow possibly causing frequent Firefox hangs
Status: RESOLVED FIXED
[Snappy]
: perf
Product: Tech Evangelism
Classification: Other
Component: Add-ons (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Matt Brubeck (:mbrubeck)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 10:05 PDT by Matt Brubeck (:mbrubeck)
Modified: 2012-07-26 19:50 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Matt Brubeck (:mbrubeck) 2012-07-25 10:05:37 PDT
A user contacted me complaining of frequent 2- to 4-second freezes when running Firefox with ~20 open tabs, with several web development add-ons installed including YSlow 3.1.2 and Firebug 1.10b4.   I asked him to try Gecko Profiler, and he sent back the following profile from a time when Firefox was acting slow:

http://people.mozilla.com/~bgirard/cleopatra/?report=869f03a73dd857485879e7c3b2f196e2f612cc48

About half the time in the profile is spent in YSlow code, with the majority of that in an anonymous function at yslow-ff-pref.js:66.
Comment 1 Matt Brubeck (:mbrubeck) 2012-07-25 10:48:49 PDT
I reported this issue to the YSlow project, with some additional details from inspecting the YSlow 3.1.2 source code: https://github.com/marcelduran/yslow/issues/49
Comment 2 Marcel Duran 2012-07-25 22:25:13 PDT
Thanks for the catch, I just removed the unused getPrefList block and increased startup timeout as an attempt to fix this issue. Please let me know if this really fix the reported issue.
Comment 3 Marcel Duran 2012-07-25 22:29:58 PDT
Just submitted a new Firefox Addon: YSlow 3.1.3 which is pending review: https://addons.mozilla.org/en-US/firefox/addon/yslow/versions/?page=1#version-3.1.3
Comment 4 Marcel Duran 2012-07-26 09:52:47 PDT
And 3.1.3 is now fully reviewed, thanks reviewers!
Comment 5 Matt Brubeck (:mbrubeck) 2012-07-26 09:58:11 PDT
Thanks!  Resolving this as fixed for now, though I can't verify it myself because I was not able to reproduce the problem.  I asked the original reporter to verify the fix, and I'll update this bug if I hear back.

Note You need to log in before you can comment on or make changes to this bug.