Last Comment Bug 777401 - DictionaryHelpers.* build problems
: DictionaryHelpers.* build problems
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: unspecified
: x86 All
: -- normal (vote)
: ---
Assigned To: Olli Pettay [:smaug]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 10:15 PDT by Olli Pettay [:smaug]
Modified: 2012-07-30 13:58 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.15 KB, patch)
2012-07-25 10:15 PDT, Olli Pettay [:smaug]
khuey: review+
Details | Diff | Splinter Review
patch (3.18 KB, patch)
2012-07-30 13:09 PDT, Olli Pettay [:smaug]
no flags Details | Diff | Splinter Review

Description Olli Pettay [:smaug] 2012-07-25 10:15:53 PDT
Created attachment 645804 [details] [diff] [review]
patch

bz saw a case when .cpp was re-created but .h wasn't.
I think this is actually because of https://hg.mozilla.org/mozilla-central/rev/252f295c4664
https://bugzilla.mozilla.org/show_bug.cgi?id=765163#c27

I'm testing the approach where .cpp and .h are always generated at the same time.

Ofc, I really don't have much experience with this kind of dependency handling in
Makefiles, so Kyle, all the comments welcome :)
Comment 1 Olli Pettay [:smaug] 2012-07-25 11:57:09 PDT
So, the patch is a bit ugly, but I'm trying to reuse the same dependencies for the .h as what
.cpp has.
Comment 2 Olli Pettay [:smaug] 2012-07-25 12:58:05 PDT
...and the patch does actually fix the problem I see. If some idl file is changed, we don't
regenerate the .h.
Comment 3 Olli Pettay [:smaug] 2012-07-25 13:29:55 PDT
Comment on attachment 645804 [details] [diff] [review]
patch

Kyle, could you accept this kind of hack, or is this too ugly, in which case should I add dependency checking specific to .h file?
Comment 4 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-07-30 13:00:15 PDT
Comment on attachment 645804 [details] [diff] [review]
patch

Review of attachment 645804 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with the change we discussed on irc.
Comment 5 Olli Pettay [:smaug] 2012-07-30 13:09:56 PDT
Created attachment 647266 [details] [diff] [review]
patch
Comment 6 Olli Pettay [:smaug] 2012-07-30 13:58:10 PDT
https://hg.mozilla.org/mozilla-central/rev/23a7ba542bb5

Note You need to log in before you can comment on or make changes to this bug.