pulling from http://hg.mozilla.org produces sporadic errors ("transaction abort! abort: 00changelog.i@887b70a4b6c2: unknown parent!")

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: jorendorff, Assigned: fox2mike)

Tracking

Details

(Reporter)

Description

6 years ago
khuey observed it:

Kyle Huey@KYLEHUEY-PC /c/dev/mozilla-central
$ hg pull -u
pulling from http://hg.mozilla.org/mozilla-central
searching for changes
adding changesets
transaction abort!
rollback completed
abort: 00changelog.i@887b70a4b6c2: unknown parent!

Kyle Huey@KYLEHUEY-PC /c/dev/mozilla-central
$ hg pull -u
pulling from http://hg.mozilla.org/mozilla-central
searching for changes
adding changesets
transaction abort!
rollback completed
abort: 00changelog.i@887b70a4b6c2: unknown parent!

Kyle Huey@KYLEHUEY-PC /c/dev/mozilla-central
$ hg in
comparing with http://hg.mozilla.org/mozilla-central
searching for changes
abort: 00changelog.i@887b70a4b6c2: unknown parent!

Kyle Huey@KYLEHUEY-PC /c/dev/mozilla-central
$ hg out
comparing with http://hg.mozilla.org/mozilla-central
searching for changes
no changes found

It's also been observed by benjamin, tedshroyer, and jduell, with similar error messages (different revision numbers).
For anyone hitting this, stackoverflow suggests that "hg verify" might give more information:
 http://stackoverflow.com/questions/2733248/unknown-parent-error-in-mercurial

Comment 2

6 years ago
I tried "hg verify" but got the same error after it ran.
(In reply to Daniel Holbert [:dholbert] from comment #1)
> For anyone hitting this, stackoverflow suggests that "hg verify" might give
> more information:
>  http://stackoverflow.com/questions/2733248/unknown-parent-error-in-mercurial
I saw the same error message on three different repos.  I think this is a server-side issue, not a client-side issue.
I believe (but I'm not 100% sure) that "hg verify" is entirely client-side -- so given that it produces the same abort (per comment 2), I think there's client-side bustage involved, too. 

(though the client-side bustage may have been directly caused by server-side bustage)
(Assignee)

Comment 5

6 years ago
Corey, Ben - Did we push 2.2.3 anywhere?

Comment 6

6 years ago
Yes, i pushed 2.2.3 to hgweb1 last night.  That node was also disabled in the load balancer.
(Assignee)

Comment 7

6 years ago
Apparently not. So guys, we're looking for a timeline of when this started happening and is this related to http://bz.selenic.com/show_bug.cgi?id=3553 or is that a completely different issue?

Comment 8

6 years ago
This is one of the symbols that I have been seeing in this bug: http://bz.selenic.com/show_bug.cgi?id=3553

Specifically see my last comment on that bug.

Comment 9

6 years ago
And yes, this is a server side issue.  The error message is actually coming from the remote.

Comment 10

6 years ago
Andreas was talking to me about how important my git mirror is yesterday, and my git mirror has been sort of broken since yesterday because of this bug...
(Assignee)

Comment 11

6 years ago
Starting now, let's see when the next failure is? The only real tweak that was made to production yesterday was we enabled a cache with a 60 second TTL. That's now been turned off. I'd like to see if that was the cause for this.
Assignee: server-ops-devservices → shyam
(In reply to Ehsan Akhgari [:ehsan] from comment #10)
> Andreas was talking to me about how important my git mirror is yesterday,
> and my git mirror has been sort of broken since yesterday because of this
> bug...

Can you explain this a bit?  Are you running your own git mirror that is being used for b2g?

Comment 13

6 years ago
Shyam,

Zeus is the wrong place to be caching.  Mercurial supports its own caching, which I am speaking with the developers about using.

Comment 14

6 years ago
(In reply to Corey Shields [:cshields] from comment #12)
> (In reply to Ehsan Akhgari [:ehsan] from comment #10)
> > Andreas was talking to me about how important my git mirror is yesterday,
> > and my git mirror has been sort of broken since yesterday because of this
> > bug...
> 
> Can you explain this a bit?  Are you running your own git mirror that is
> being used for b2g?

Yes.  I pull from m-c and inbound, convert stuff to git, and then push them to https://github.com/mozilla/mozilla-central and b2g uses that repository.

Comment 15

6 years ago
For the benefit of people not reading our IRC conversation, now that IT has disabled the caching that was put in place yesterday, I'm testing this very aggressively to see if it happens again.
This should be fixed, please reopen if that is not the case.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 17

6 years ago
It is definitely fixed.
Status: RESOLVED → VERIFIED
Component: Server Operations: Developer Services → General
Product: mozilla.org → Developer Services
You need to log in before you can comment on or make changes to this bug.