keybindings shouldn't show in menu if they are overridden

VERIFIED DUPLICATE of bug 71779

Status

()

Core
XUL
VERIFIED DUPLICATE of bug 71779
17 years ago
9 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({polish, pp})

Trunk
mozilla1.1alpha
x86
Linux
polish, pp
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
summary sez it all. on linux [unix], in the composer [editor] and mail/aim
compose windows, control+A [assuming control is the accelerator key used] should
be removed since doing that will go to the beginning of the line [not Select
All]. control+A does Select All only in the browser, mail message pane, and mail
standalone windows.
(Reporter)

Comment 1

17 years ago
adding pp: unix only.
Keywords: polish, pp
(Reporter)

Comment 2

17 years ago
to clarify: on win32/mac, control/command+A is supposed to Select All in all
those windows.
(Assignee)

Comment 3

17 years ago
content, not toolkit
Assignee: pinkerton → akkana

Comment 4

17 years ago
this isn't actually content... back to Pinkerton with a new summary

This bug is for the case where keybindings are overridden by the platform in some 
or all cases but the keybinding still shows up in the menu.
Summary: Ctrl+A needs to be removed for Select All in composer and mail/aim compose windows → keybindings shouldn't show in menu if they are overridden

Comment 5

17 years ago
-->pink with new summary
Assignee: akkana → pinkerton
(Assignee)

Comment 6

17 years ago
okies.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.1

Comment 7

17 years ago
Probably a dup of bug 71779.

Comment 8

17 years ago
yes, that is the bug I was thinking of; thanks Akkana!


*** This bug has been marked as a duplicate of 71779 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 9

17 years ago
zap.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.