"New Subfolder" on IMAP server does not create valid subfolder

RESOLVED INVALID

Status

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: rohlfing, Unassigned)

Tracking

14 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 645846 [details]
Screenshot of existing super-folder and wrongly created folder

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120717144008

Steps to reproduce:

1. Right-click on existing folder on IMAP server, say folder name is "Journals", which already contains a number of existing subfolders.
2. Select "New Subfolder..."
3. Enter "Frontiers" as "Name" and click "Create" button


Actual results:

Instead of creating a new subfolder "Journals" -> "Frontiers", an apparent new folder named "Journals^Frontiers" is created at the same hierarchy level as the existing "Journals" folder.

This used to work prior to approximately Thunderbird 12, but was already broken in 13. No change to the imap server has happened within the timeframe when this broke. 

I am not the IMAP server admin, but it is imapd running on Fedora Linux, and I believe this connection response has the version number:

AP4rev1 2007e.404


Expected results:

A sub-folder "Journals"->"Frontiers" should have been created
(Q1) Does your problem occur on any subfolder creation of any parent folder of the IMAP account? Or on Frontiers under Journals only problem?

In screen shot, folder is shown as "Journals^F...formatics". i indicates that actual subfolder name you requested was never "Frontiers".
(Q2) What is actual string?

(Q3) When did your problem start to occur? (after upgrade Tb, etc.)
(Q4) How and by whom was other existent subfolders under Journals created?

"^ at -> in Journals->Frontiers format"(mbox hierarchy delimiter position) is observed in bug 697789. Similar "^" is also seen in bug 773579.
In any case, mbox hierarchy delimiter was "." instead of "/".

(Q5) Can you get and attach(not paste) IMAP log? ( see bug 402793 comment #28 )
Command/response for CAPABILITY, NAMESPACE, LSUB, LIST, SELECT of mbox used by namespace and parent(Journals in your case), and CREATE, SUBSCRIBE, SELECT of the created folder, is needed. 
Any other data such as mail related data is not needed. Delete other data and reduce log data volume, please.
If you need to open log data to public, remove/replace personal info, please.
(Reporter)

Comment 2

6 years ago
So I noticed that when I tried the folder creation from a different computer (with independent user/account profiles) then things worked fine, despite using identical TB version.

I deleted my IMAP account and created it from scratch, and now it works, so it seems there was some leftover information in my profile (which has been continuously updated since, oh, 2004) that screwed things up.

Suppose the proper thing to do is close this bug.

For what it's worth, here are the answers to your questions also:

(Q1) any folder
(Q2) I tried multiple different folder names; the screen shot wasn't the final state, sorry.
(Q3) can't say for sure - I upgrade from the Fedora repos whenever there is an update, but I don't create folders much.
(Q4) created with earlier tb version by myself.
(Q5) sorry, don't have access to the logs
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.