XUL iframe doesn't scroll with XUL content

RESOLVED INVALID

Status

()

Core
XUL
RESOLVED INVALID
17 years ago
10 years ago

People

(Reporter: Mike Potter, Assigned: Eric Vaughan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
If you make an iframe and set its source to "chrome://'any xul file'", if the
content is too large scrollbars will not automatically appear.
They do appear if the content is staight HTML.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 73466 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
I don't think this is a duplicate bug as shown.  The problem is that with XUL
content, the content does not scroll, but with regular HTML content, it scrolls
no problem.  That is not a request for enhancement, I think its a genuine bug.

Comment 3

17 years ago
I disagree as well.  My request is for a XUL attribute which will allow a
programmer to manually turn on or off scrolling, not to automatically have
scrolling appear when it rightfully should (which is what this bug is).  These
are 2 clearly different problems, this being one which genuinely can make life hell.

Comment 4

17 years ago
Okay reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

17 years ago
->evaughan
Assignee: trudelle → evaughan

Comment 6

17 years ago
By default XUL iframes do not have scrollbars. If you want them to scroll make a
CSS rule "overflow: auto" for yours.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

17 years ago
But the IFRAME does get a scroll bar if the src is set to a straight HTML file,
so I don't think this is invalid.  
It seems silly to have different settings based on whether the content is HTML
or XUL.

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.