Closed Bug 777552 Opened 7 years ago Closed 7 years ago

crash in nsChromeTreeOwner::SetTitle (sending a message)

Categories

(MailNews Core :: Networking, defect, critical)

x86_64
All
defect
Not set
critical

Tracking

(thunderbird17 affected, seamonkey2.14 affected)

VERIFIED DUPLICATE of bug 777063
Tracking Status
thunderbird17 --- affected
seamonkey2.14 --- affected

People

(Reporter: tonymec, Unassigned)

Details

(Keywords: crash, regression, topcrash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-a9e21907-cc25-4b01-8e08-d574a2120725 .
============================================================= 

Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Firefox/17.0 SeaMonkey/2.14a1 ID:20120725003016 CSet: 3f7c3f228397 m-c: ef20925bc2a5

Reproducible: Didn't try

Crash happened while sending an email message. After restart, it was found that the message (to a mailing list) had been sent, since I got back a copy from the list server. This is of course not bug 69798 which was FIXED in 2001.

Robert: Did you report the problem you had Tuesday during the SeaMonkey status meeting? I couldn't find it back; does it resemble this one?

Wayne: Does this also happen on recent Thunderbird builds? (Tuesday 24 Jul. and later)

Here comes the crash report:

Signature 	nsChromeTreeOwner::SetTitle
UUID	a9e21907-cc25-4b01-8e08-d574a2120725
Date Processed	2012-07-25 22:49:56
Uptime	15252
Last Crash	1.1 weeks before submission
Install Age	4.4 hours since version was first installed.
Install Time	2012-07-25 18:23:11
Product	SeaMonkey
Version	2.14a1
Build ID	20120725003016
Release Channel	nightly
OS	Linux
OS Version	0.0.0 Linux 3.1.10-1.16-desktop #1 SMP PREEMPT Wed Jun 27 05:21:40 UTC 2012 (d016078) x86_64
Build Architecture	amd64
Build Architecture Info	family 15 model 4 stepping 1
Crash Reason	SIGSEGV
Crash Address	0xc0
User Comments	sending an email
App Notes 	

GLXtest process failed (exited with status 1): X error occurred in GLX probe, error_code=9, request_code=55, minor_code=0



WebGL? WebGL- 

Processor Notes 	
EMCheckCompatibility	False
Winsock LSP	

Adapter Vendor ID	
Adapter Device ID	

Bugzilla - Report this bug in SeaMonkey, Core, Plug-Ins, or Toolkit
Crashing Thread
Frame 	Module 	Signature 	Source
0 	libxul.so 	nsChromeTreeOwner::SetTitle 	xpfe/appshell/src/nsChromeTreeOwner.cpp:471
1 	libxul.so 	nsDocShell::SetTitle 	docshell/base/nsDocShell.cpp:5126
2 	libxul.so 	nsDocument::DoNotifyPossibleTitleChange 	content/base/src/nsDocument.cpp:5258
3 	libxul.so 	nsRunnableMethodImpl<void , false>::Run 	nsThreadUtils.h:349
4 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:624
5 	libxul.so 	NS_ProcessNextEvent_P 	objdir/mozilla/xpcom/build/nsThreadUtils.cpp:217
6 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:82
7 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
8 	libxul.so 	nsBaseAppShell::Run 	widget/xpwidgets/nsBaseAppShell.cpp:163
9 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:271
10 	libxul.so 	XREMain::XRE_mainRun 	toolkit/xre/nsAppRunner.cpp:3787
11 	libxul.so 	XREMain::XRE_main 	toolkit/xre/nsAppRunner.cpp:3864
12 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3940
13 	seamonkey 	main 	suite/app/nsSuiteApp.cpp:173
14 	libc-2.14.1.so 	libc-2.14.1.so@0x2123c 	
15 	seamonkey 	nsGetterAddRefs<nsIFile>::operator nsIFile**
Hm. Problem seems to happen fairly frequently today, and occasionally yesterday, on both SeaMonkey and Thunderbird; see https://crash-stats.mozilla.com/report/list?signature=nsChromeTreeOwner%3A%3ASetTitle

This signature is currently the #5 topcrasher for Thunderbird 17.0a1.
Component: MailNews: Message Display → Networking
Product: SeaMonkey → MailNews Core
P.S. Crash seen only on Linux64 thus far; and at least on openSUSE and Ubuntu.
#3 crasher when combined with nsChromeTreeOwner::SetTitle(wchar_t const*) 
first crash build is 20120724030551.

no firefox trunk crashes. a couple rare FF 14 crashes.
Crash Signature: [@ nsChromeTreeOwner::SetTitle] → [@ nsChromeTreeOwner::SetTitle] [@ nsChromeTreeOwner::SetTitle(wchar_t const*) ]
OS: Linux → All
I think this is a dupe of bug 777063.
agree
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 777063
Bug 777063 summary mentions HTML mail; I was sending plaintext mail. But if their top stack items, until and including the signal handler, are removed, then it looks very like my stack.
Problem does NOT happen every time (I just sent an email with no crash).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.