Last Comment Bug 777647 - IonMonkey: Four jit-tests assert: !hasLazyType()
: IonMonkey: Four jit-tests assert: !hasLazyType()
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem]
:
Mentors:
Depends on:
Blocks: IonGreen
  Show dependency treegraph
 
Reported: 2012-07-26 00:45 PDT by David Anderson [:dvander]
Modified: 2012-07-27 13:10 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.21 KB, patch)
2012-07-26 02:23 PDT, Jan de Mooij [:jandem]
dvander: review+
Details | Diff | Review

Description David Anderson [:dvander] 2012-07-26 00:45:54 PDT
This assert is firing on four tests, that can be found by running jit-tests with --ion. One of the tests is testCallApply (I can't see the others right now since TBPL is down).

This is most likely a regression from the TI patch that fixed v8-raytrace, which we took in a recent merge.
Comment 1 David Anderson [:dvander] 2012-07-26 01:13:48 PDT
This will also fix the crash on Mochitest column 1 seen only in debug builds.
Comment 2 Jan de Mooij [:jandem] 2012-07-26 02:23:59 PDT
Created attachment 646071 [details] [diff] [review]
Patch

If UseNewTypeForClone is true, we have to give the clone a singleton type and clone the script, we don't want the fast path to handle these cases.
Comment 3 David Anderson [:dvander] 2012-07-27 13:10:13 PDT
http://hg.mozilla.org/projects/ionmonkey/rev/1274d6819bae

Note You need to log in before you can comment on or make changes to this bug.