Closed Bug 777649 Opened 8 years ago Closed 8 years ago

'Remove' context menu is broken for Top Sites awesomescreen entries

Categories

(Firefox for Android :: Awesomescreen, defect)

15 Branch
ARM
Android
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 17
Tracking Status
firefox14 --- unaffected
firefox16 + verified
firefox17 + verified
firefox18 --- verified

People

(Reporter: pretzer, Assigned: wesj)

References

Details

Attachments

(1 file)

The 'Remove' context menu action of entries on the awesomescreen Top Sites tab is broken. The toast message that the entry was removed is shown, but the entry stays where it was.
The 'Remove' action on the History tab is working as expected.
I reproduced this on the current Nightly. Not sure about Aurora and Beta, but the 'remove' menu item was introduced in 15, so FF14 is unaffected.
tracking-fennec: --- → ?
Depends on: 763036
Attached patch PatchSplinter Review
Silly me used the wrong ID when I moved this over.
Assignee: nobody → wjohnston
Attachment #646219 - Flags: review?(margaret.leibovic)
Comment on attachment 646219 [details] [diff] [review]
Patch

Can you also update the comment in here (and the same copy/pasted comment in BookmarksTab) to reflect the new state of things. You can probably get rid of the comment in BookmarksTab, but it could be worth noting in here why we're using the HISTORY_ID.
Attachment #646219 - Flags: review?(margaret.leibovic) → review+
Comment on attachment 646219 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 759041
User impact if declined: Remove option doesn't work
Testing completed (on m-c, etc.): Landing on mc now
Risk to taking this patch (and alternatives if risky): Very low risk. Remove doesn't work without this. Fixes a regression from 14 introduced during a refactor. Returns to the old behavior.
String or UUID changes made by this patch: None.
Attachment #646219 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/a9fcfa1a0d69
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 17
Attachment #646219 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.