Closed Bug 777663 Opened 7 years ago Closed 7 years ago

Hint text for Password field is not translated when Master Password popup is triggered

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 17
Tracking Status
firefox15 --- verified
firefox16 --- verified
firefox17 --- verified

People

(Reporter: xti, Assigned: wesj)

References

Details

Attachments

(2 files)

Attached image screenshot
Firefox 15.0b2 (2012-07-24)
Device: Acer Iconia TAB A500
OS: Android 3.2

Steps to reproduce:
1. Change the OS language to ru-RU
2. Open Firefox
3. Go to Menu > Settings > Use Master Password and set a Master Password
4. Go to gmail.com and login
5. When Master Password popup is triggered, verify if the hint text for Password field is translated

Expected result:
"Password" hint text is translated to ru-RU

Actual result:
"Password" hint text is not translated (see attached screenshot)
(In reply to Cristian Nicolae (:xti) from comment #0)
> Created attachment 646072 [details]
> screenshot
> 
> Firefox 15.0b2 (2012-07-24)
> Device: Acer Iconia TAB A500
> OS: Android 3.2
> 
> Steps to reproduce:
> 1. Change the OS language to ru-RU
> 2. Open Firefox
> 3. Go to Menu > Settings > Use Master Password and set a Master Password
> 4. Go to gmail.com and login
> 5. When Master Password popup is triggered, verify if the hint text for
> Password field is translated
> 
> Expected result:
> "Password" hint text is translated to ru-RU
> 
> Actual result:
> "Password" hint text is not translated (see attached screenshot)

Have you tested another localization? I think that "Password" hint text for Master Password is hardcoded in English - http://mxr.mozilla.org/mozilla-central/source/mobile/android/components/PromptService.js#264
(In reply to Alexander L. Slovesnik from comment #1)
> Have you tested another localization? I think that "Password" hint text for
> Master Password is hardcoded in English -
> http://mxr.mozilla.org/mozilla-central/source/mobile/android/components/
> PromptService.js#264

If I go to Settings and I try to disable the Master Password, when the MP popup is triggered, the hint text is translated and that's why I thought that the hint text should be translated everywhere.
I tend to agree with Alexander here, moving over to Firefox. I think Wes wrote the prompt code originally in bug 694455.

http://hg.mozilla.org/mozilla-central/rev/859fc2a73a59#l7.382 doesn't translate the Password hint, while http://hg.mozilla.org/mozilla-central/rev/859fc2a73a59#l7.412 does.

Should be safe to re-use the existing string from my glimpse at mxr, fwiw.

Christian, it'd be good to verify on other languages.

FWIW, the russian string that's tagged with 15b2 is http://hg.mozilla.org/releases/l10n/mozilla-beta/ru/file/1103a40a4bb8/mobile/overrides/passwordmgr.properties#l37
Component: ru / Russian → General
Product: Mozilla Localizations → Firefox for Android
(In reply to Axel Hecht [:Pike] from comment #3)
> I tend to agree with Alexander here, moving over to Firefox. I think Wes
> wrote the prompt code originally in bug 694455.
> 
> http://hg.mozilla.org/mozilla-central/rev/859fc2a73a59#l7.382 doesn't
> translate the Password hint, while
> http://hg.mozilla.org/mozilla-central/rev/859fc2a73a59#l7.412 does.
> 
> Should be safe to re-use the existing string from my glimpse at mxr, fwiw.
> 
> Christian, it'd be good to verify on other languages.
> 
> FWIW, the russian string that's tagged with 15b2 is
> http://hg.mozilla.org/releases/l10n/mozilla-beta/ru/file/1103a40a4bb8/mobile/
> overrides/passwordmgr.properties#l37

I verified several languages so far (l10n testing is in progress for 15b2) and there is the same issue. I filled a bug for each tested language, but in this case all be wontfix.
I'd resolve those as dupes of this one.
Summary: [ru-RU] Hint text for Password field is not translated when Master Password popup is triggered → Hint text for Password field is not translated when Master Password popup is triggered
Attached patch PatchSplinter Review
Testing locally, but this should be right....
Assignee: nobody → wjohnston
Attachment #646167 - Flags: review?(mbrubeck)
Attachment #646167 - Flags: review?(mbrubeck) → review+
Comment on attachment 646167 [details] [diff] [review]
Patch

If we're moving things up, this is super low risk and helpful for non-english speakers. Affects release, aurora, and beta.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Since the prompt service began
User impact if declined: Unlocalized hint for password prompts
Testing completed (on m-c, etc.): landed on mc today
Risk to taking this patch (and alternatives if risky): Very low risk. Mobile only. Uses a string that's already there, shared with Desktop firefox
String or UUID changes made by this patch: Uses an already existing string that was being used in other password type prompts (i.e. Username and password prompts). Nothing new.
Attachment #646167 - Flags: approval-mozilla-beta?
Attachment #646167 - Flags: approval-mozilla-aurora?
Comment on attachment 646167 [details] [diff] [review]
Patch

[Triage Comment]
Low risk code change to utilize an existing string, as opposed to adding a new one to DTD files. Approving for branches.
Attachment #646167 - Flags: approval-mozilla-beta?
Attachment #646167 - Flags: approval-mozilla-beta+
Attachment #646167 - Flags: approval-mozilla-aurora?
Attachment #646167 - Flags: approval-mozilla-aurora+
Duplicate of this bug: 777636
Duplicate of this bug: 777645
Duplicate of this bug: 777655
Duplicate of this bug: 777660
https://hg.mozilla.org/mozilla-central/rev/9118c1ca0aac
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 17
Now everything works as expected. Closing bug as verified fixed.

--
Device: Galaxy Nexus
OS: Android 4.0.4
You need to log in before you can comment on or make changes to this bug.