Support live thumbnails for tab bar

RESOLVED FIXED

Status

Firefox for Metro
General
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: jimm, Assigned: jwilde)

Tracking

(Depends on: 1 bug)

Trunk
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: completed-elm)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 646165 [details]
testcase

related: bug 777745 (html5 video)

STR: 

1) load the testcase
2) once the content area turns blue, right-click or swipe to bring up the tab bar
3) wait for the content are to turn red

results: thumbnail remains blue
expected: thumbnail should turn red
(Assignee)

Comment 1

6 years ago
This is because the tab thumbnail code is old and periodically pulls thumbnails with JS and stores them on a <canvas> element.  The only way to currently to get them to update is to resize the page.

It sounds like we could use -moz-element to both simplify the thumbnail code and get live thumbnails in one patch.

Since bug 777745 is caused by the same underlying issue and this bug has a more concise description of the lower-level problem than 777745, I'm marking bug 777745 as duplicate and track progress.
Status: NEW → ASSIGNED
(Assignee)

Updated

6 years ago
Duplicate of this bug: 777745
(Assignee)

Updated

6 years ago
Assignee: nobody → jonathan
Summary: tab bar thumbnails don't update when content changes → Support live thumbnails for tab bar

Comment 4

6 years ago
While I would have used -moz-element too, do note that this is not compatible with e10s as I understand it. To be clear, I am completely okay with breaking compatibility with e10s like this, and for the "nsIDOMWindowUtils and bug 577579" stuff that you're working on, I'd worry less about e10s in the process of getting events to work.
(Assignee)

Comment 5

6 years ago
(In reply to Frank Yan (:fryn) from comment #4)
> While I would have used -moz-element too, do note that this is not
> compatible with e10s as I understand it. 

Confirmed: bug 714883.

> To be clear, I am completely okay
> with breaking compatibility with e10s like this, and for the
> "nsIDOMWindowUtils and bug 577579" stuff that you're working on, I'd worry
> less about e10s in the process of getting events to work.

That's good idea, as it's looking more and more like the overhead of trying not to break e10s will drag down everything else.
(Assignee)

Comment 6

6 years ago
Apparently sessionstore broke because it assumed that there was a canvas to push content into.  For the time being, I've ripped this functionality out.  In the future, for improved perceived performance, we might want to recreate the thumbnail as done here, then get rid of that canvas, when the page is delay-loaded.

http://hg.mozilla.org/projects/elm/rev/ca52f2c307e5
(Reporter)

Updated

6 years ago
Component: General → General
Product: Firefox → Firefox for Metro

Updated

5 years ago
Depends on: 831440

Updated

5 years ago
Blocks: 831440
Depends on: 644362
No longer depends on: 831440
Resolving bugs in the Firefox for Metro product that are fixed on the elm branch.  Sorry for the bugspam.  Search your email for "bugspam-elm" if you want to find and delete all of these messages at once.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.