Intermittent css-gradients/linear-1a.html | image comparison (==) (and 13 more)

RESOLVED WORKSFORME

Status

()

Core
CSS Parsing and Computation
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86
Windows 7
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
This was first seen to occur on:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=ff942348efc9

However, on builds on which it does occur, it happens for every single Win7 debug reftest retrigger. If the build is retriggered, the resultant reftest with the new build goes green. I presume this is indicative of a compiler issue.

I have retriggered a number of Win7 debug builds leading up to the initial occurrence, but didn't get anything breaking earlier. See:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=ff942348efc9&jobname=Rev3%20WINNT%206.1%20mozilla-inbound%20debug%20test%20reftest
(and keep on pressing the down arrow)

----

Rev3 WINNT 6.1 mozilla-inbound debug test reftest on 2012-07-25 17:03:48 PDT for push ff942348efc9

slave: talos-r3-w7-068

https://tbpl.mozilla.org/php/getParsedLog.php?id=13856307&tree=Mozilla-Inbound

{
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/css-gradients/linear-1a.html | image comparison (==)
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/css-gradients/linear-1b.html | image comparison (==)
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/css-gradients/linear-repeat-1a.html | image comparison (==)
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/css-gradients/linear-vertical-1a.html | image comparison (==)
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/css-gradients/linear-vertical-1b.html | image comparison (==)
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/css-gradients/linear-vertical-1c.html | image comparison (==)
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/css-gradients/linear-vertical-1d.html | image comparison (==)
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/css-gradients/linear-vertical-1e.html | image comparison (==)
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/css-gradients/aja-linear-1a.html | image comparison (==)
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/css-gradients/aja-linear-1e.html | image comparison (==)
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/css-gradients/aja-linear-1f.html | image comparison (==)
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/css-gradients/aja-linear-4a.html | image comparison (==)
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/css-gradients/aja-linear-4b.html | image comparison (==)
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/css-gradients/aja-linear-5a.html | image comparison (==)
}

On the same push as the above, the failed retriggers were:
https://tbpl.mozilla.org/php/getParsedLog.php?id=13861750&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=13873986&tree=Mozilla-Inbound

Marking blocking bug 768775, since that's the only relevant thing I can spot from skim reading commits leading up to this failure.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Hmm, did a clobber actually fix it for inbound? Trying that theory out on aurora...
Though I could have just looked at the builds - the builds for every green run since https://tbpl.mozilla.org/?tree=Mozilla-Aurora&rev=8b243972bf82 have said they were clobbers, the builds for every failing run have not.

Resolved buildsystemisbroken.
(Reporter)

Comment 14

6 years ago
(In reply to Phil Ringnalda (:philor) from comment #13)
> Resolved buildsystemisbroken.

Something similar to bug 766793 perhaps?
Comment hidden (Treeherder Robot)
Probably so, or not, and maybe similar to tonight's mozilla-inbound closure, or not.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Comment hidden (Treeherder Robot)
(Assignee)

Updated

5 years ago
Keywords: intermittent-failure
(Assignee)

Updated

5 years ago
Whiteboard: [orange]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.