Closed Bug 777756 Opened 8 years ago Closed 8 years ago

Responsive Design View : Allow users to add custom viewport size

Categories

(DevTools :: General, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 762846

People

(Reporter: Jeremie, Unassigned)

Details

Attachments

(1 file)

Attached image UI Mockup
It would be nice to have a way to allow users to add custom viewport size on the dropdown menu of the Responsive Design View.

For now, you can have only one custom size and you can set this size only by adjusting the view port with your mouse.

I added a quick mockup to figure what the UI of such a feature could look like.
In bug 762846, Hubert works on the inner mechanism.
Please discuss the UI there (and I do like the mockup, and I'm curious about the button. It looks more like a "leave responsive mode" button)

See bug 762848 as well.
And bug 767678 too.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 762846
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.