If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

Add-on SDK
General
P2
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: irakli, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Currently constructors / classes exposed by an add-on sdk can not be subclassed / extended. Fixing this would enable users to subclass Panel, Widget etc... to implement MegaPanel, MegaWidget, ... custom APIs that have more functionality.
Depends on: 777821

Updated

5 years ago
Priority: -- → P2
Duplicate of this bug: 665811
We use core/heritage pretty much everywhere now except Windows/Tabs which is bug 854982, and widgets which will be removed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Depends on: 854982
Resolution: --- → FIXED
Depends on: 854990
I'm not sure we can say is it fixed. Simply using `Class` doesn't makes our APIs extendable. To be more precise, we can extend `PageMod` for example, but we can't access to the content's sandboxes from the subclass, so it's pretty useless, we basically obtain the same functionality to "wrap" the `PageMod` instead of subclass it.

So, if this bug is about using `core/heritage` in all our APIs I agree can be considered fixed (but then let's update the title); otherwise I don't think it should be marked as resolved.
You need to log in before you can comment on or make changes to this bug.