<select> dropdown box doesn't expand beyond 1 option on redraw

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: Jason Ng, Unassigned)

Tracking

({regression})

16 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 646258 [details]
Only first option shown with Firebug window open

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0
Build ID: 20120726042008

Steps to reproduce:

For a page with survey, that has sections are hidden/shown.  A previously hidden section, was revealed with <select> boxes.


Actual results:

The dropdown of the select shows only 1 option, usually the first option "choose".  The other options can be still picked by using the arrow keys and the mouse wheel.

This behaviour happens with a Firebug window open, in the given example attachment.  

But for the full page the attachment was based on, it happens even with add-ons disabled.  

I have not been able to reproduce this with very simplified versions of the same things.  Which leads me to conclude there must be something with memory that's affecting how the <select>'s dropdowns are being rendered.


Expected results:

The <select> dropdown shows all the options it can reasonably display on a screen.

Updated

6 years ago
Attachment #646258 - Attachment mime type: text/plain → text/html
(Reporter)

Updated

6 years ago
Summary: <select> dropdown box doesn't expand beyond 1 option → <select> dropdown box doesn't expand beyond 1 option on redraw
(Reporter)

Comment 1

6 years ago
This seems to only happen on redraw, as <select> boxes that appear right away when the page is loaded will always be fine.  It's ones that are hidden and then made visible.

Comment 2

6 years ago
Created attachment 647669 [details]
Minimal testcase for the problem

I had this bug trigger on my website, so I've created a minimal testcase for the problem as seen on 16.0a2. Refresh while scrolled to the top for an intact list; refresh while scrolled to the bottom for a list with only one item.

Updated

6 years ago
Attachment #647669 - Attachment mime type: text/plain → text/html

Comment 3

6 years ago
This is a regression since 14.0.1 and 15.0b2 both work correctly.

Comment 4

6 years ago
This seems to be fixed on the latest Nightly build (was fixed this week I think).

Comment 5

5 years ago
This video shows this bug in action, and how it's just Firefox 16:

http://www.youtube.com/watch?v=OufMGLGZAls&feature=youtu.be

Seriously though folks, as Firefox has auto-updates enabled by default this kind of bug is simply unacceptable. SLOW DOWN guys, you're breaking things.

Comment 6

3 years ago
Resolving per comment 4. Please reopen if it's still a problem with a current version.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Keywords: regression
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.