Last Comment Bug 777871 - Get B2G mochitests running out-of-process
: Get B2G mochitests running out-of-process
Status: RESOLVED FIXED
:
Product: Testing
Classification: Components
Component: Mochitest (show other bugs)
: unspecified
: All Gonk (Firefox OS)
-- normal (vote)
: mozilla17
Assigned To: Jonathan Griffin (:jgriffin)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 12:54 PDT by Jonathan Griffin (:jgriffin)
Modified: 2012-08-02 13:31 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch v0.1 (3.08 KB, patch)
2012-08-01 16:10 PDT, Jonathan Griffin (:jgriffin)
justin.lebar+bug: review+
Details | Diff | Splinter Review

Description User image Jonathan Griffin (:jgriffin) 2012-07-26 12:54:07 PDT
According to justin, the way we're running mochitests right now in B2G is not out-of-process.  In order to do so:

"Ideally, you'd run the whole mochitest suite both from shell.xul and
from inside <iframe mozbrowser>, which, if you have the right
permissions set, will run OOP.  See the bottom of
dom/browser-element/mochitest/BrowserElementTestHelpers.js for the
prefs you'd need to set, although many of these are probably already
set correctly for you in b2g's existing prefs file."
Comment 1 User image Justin Lebar (not reading bugmail) 2012-07-27 07:28:56 PDT
See also bug 778072, which is the same thing, but for reftests.
Comment 2 User image Jonathan Griffin (:jgriffin) 2012-08-01 16:10:03 PDT
Created attachment 648132 [details] [diff] [review]
patch v0.1

This patch adds the necessary prefs to run mochitest in OOP mode on B2G.  It also explicitly loads mochitest in the 'homescreen' mozbrowser element.

I believe this patch works as intended.  Before the patch, running mochitests resulted in only 1 B2G process: /system/b2g/b2g. Now, there are two, the former plus /system/b2g/plugin-container, and the latter's memory consumption varies considerably during the tests.
Comment 3 User image Justin Lebar (not reading bugmail) 2012-08-02 07:33:35 PDT
Comment on attachment 648132 [details] [diff] [review]
patch v0.1

Okay!
Comment 4 User image Jonathan Griffin (:jgriffin) 2012-08-02 13:31:21 PDT
http://hg.mozilla.org/mozilla-central/rev/0f66a7ecf8de

Note You need to log in before you can comment on or make changes to this bug.