huge memory consumption ("heap-unclassified") when in Outlook web access

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: Kuno Meyer, Assigned: virgil)

Tracking

15 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink:P2])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 646314 [details]
OWA memory consumption.png

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120717110313

Steps to reproduce:

1) start FF with add-ons disabled
2) login into an Outlook Web Access (version 14.1) account
3) observe that "heap-unclassified" increases by about 300-400 MB
4) close the tab and wait some time. RAM consumption normalizes. (Note: "minimize memory usage" in about:memory doesn't accelerate this.)

Do the same with IE 9 or Chrome 20: neither of them uses more than, say, 40-60 MB

See attached chart.


Actual results:

Firefox uses roughly 5x as much memory as other browsers when logging into Outlook Web Access. The memory shows up as "heap unclassified" and is freed some times after closing the tab. 

It is not clear why the memory consumption is that high. Obviously, Firefox does something much less space efficient that the others (Chrome / IE).
Or Gecko gets other code than other browsers (via UA sniffing).
I don't know what I should Do with this bug report since you need access to OWA
(Reporter)

Comment 2

6 years ago
Just thought this might be of interest, in times of the ongoing MemShrink efforts.

I cannot provide you with an OWA web account, but if there is something that can be done that does no go as far as downloading sources and SDK and compiling FF by myself, I am willing to help.
(Assignee)

Comment 3

6 years ago
Adding Memshrink to the whiteboard. If there is any need in the long run I think I can also find an account to test with.
Whiteboard: [MemShrink]
Whiteboard: [MemShrink] → [MemShrink:P2]
Virgil, if you can get us access to an OWA instance, we'll be able to run DMD on the browser and investigate further.  Would you mind taking this bug?
Assignee: nobody → virgil.dicu
(Assignee)

Comment 5

6 years ago
So...the IT guys here created me an OWA account.

I can't reproduce the issue on Vista with F15b5. The account is absolutely empty, which I assume might be one of the reasons why I can't reproduce

Justin/Nick: any ideas what might help in reproducing here? I'll try to find a way to populate my inbox. Is there anything else that might help here?
> I'll try to find a way to populate my inbox. Is there anything else that might help here?

If the STR in comment 0 are just "log in", populating your inbox seems like a good bet.  Perhaps you also need some contacts or something, but that seems unlikely to me.
(Reporter)

Comment 7

6 years ago
Yes, just "log in". 

"Log in" means to me having "Use Outlook Wep App Light" set to OFF and the security option set to "This is a private computer".

I can reproduce the issue with two different instances of OWA. One is OWA 14.1 and roughly contains 35 items (HTML mails) in the main folder of the Inbox, the other one is OWA 14.2 and has about 60 Items in the Inbox main folder.

I use the three-pane view mode (left pane: folder tree, middle pane: messages, right pane: content of the selected message).
(Reporter)

Comment 8

6 years ago
Just received FF 16b1 this morning. With that version, I cannot any more reproduce the issue described in this bug report.
(Assignee)

Comment 9

6 years ago
Sorry for the delay from my part here, but I'm waiting on IT to resolve a ticket with the account - they have to change some exchange server. 

(In reply to Kuno Meyer from comment #8)
> Just received FF 16b1 this morning. With that version, I cannot any more
> reproduce the issue described in this bug report.

If/when they'll eventually resolve this in IT, I will check again on 15 with info in comment 7, but it's still nice to hear this is solved.
Closing, based on comment 8.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME

Comment 11

5 years ago
This bug just occurs again using FF 27.0.1 in combination with the newest OWA 2012. I have this bug both on my laptop (Windows XP) and on my Desktop (Windows 7). Using a blank profile does not solve the problem. A workmate has windows 7, too - but is not affected.

Comment 12

4 years ago
I noticed this bug in FF 30 in combination with OWA 2010. I'm using Fedora 20 on my laptop.
Earlier I was using my pervious profile backup.
Once I noticed this issue created new profile and even this issue is there.
You need to log in before you can comment on or make changes to this bug.