Last Comment Bug 777942 - Add a label to nsDOMStorage::GetItem()
: Add a label to nsDOMStorage::GetItem()
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla17
Assigned To: Jeff Muizelaar [:jrmuizel]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 14:39 PDT by Jeff Muizelaar [:jrmuizel]
Modified: 2012-07-28 18:37 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add a label to nsDOMStorage::GetItem() (436 bytes, patch)
2012-07-26 14:39 PDT, Jeff Muizelaar [:jrmuizel]
ehsan: review+
Details | Diff | Splinter Review
Add labels to the parts of GetItem that are likely to take a long time. (1.44 KB, patch)
2012-07-27 10:45 PDT, Jeff Muizelaar [:jrmuizel]
ehsan: review+
Details | Diff | Splinter Review

Description Jeff Muizelaar [:jrmuizel] 2012-07-26 14:39:30 PDT
Created attachment 646353 [details] [diff] [review]
Add a label to nsDOMStorage::GetItem()

This call can take a long time because it can require main thread IO
Comment 1 Olli Pettay [:smaug] 2012-07-26 15:04:42 PDT
I asked this before, but have forgotten the answer: how much does a SAMPLE_LABEL
slow down performance in release builds?
Comment 2 Olli Pettay [:smaug] 2012-07-26 15:05:14 PDT
...should we sample only the case when I/O is actually needed?
Comment 3 :Ehsan Akhgari 2012-07-26 15:11:33 PDT
(In reply to comment #1)
> I asked this before, but have forgotten the answer: how much does a
> SAMPLE_LABEL
> slow down performance in release builds?

It creates a SamplerStackFrameRAII object on the stack: http://mxr.mozilla.org/mozilla-central/source/tools/profiler/sps_sampler.h#154
Comment 4 :Ehsan Akhgari 2012-07-26 15:19:31 PDT
Comment on attachment 646353 [details] [diff] [review]
Add a label to nsDOMStorage::GetItem()

(As discussed on IRC, please move this sample to the IO case).
Comment 5 Jeff Muizelaar [:jrmuizel] 2012-07-27 10:45:16 PDT
Created attachment 646626 [details] [diff] [review]
Add labels to the parts of GetItem that are likely to take a long time.

This adds labels for the sqlite and cross process implementations.
Comment 6 Jeff Muizelaar [:jrmuizel] 2012-07-27 11:59:47 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/38fd00ed7571
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-07-28 18:37:09 PDT
https://hg.mozilla.org/mozilla-central/rev/38fd00ed7571

Note You need to log in before you can comment on or make changes to this bug.