[traceback] DoesNotExist: ThreadedComment matching query does not exist.

RESOLVED DUPLICATE of bug 773480

Status

Mozilla Developer Network
Wiki pages
P2
major
RESOLVED DUPLICATE of bug 773480
6 years ago
4 years ago

People

(Reporter: stephend, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

6 years ago
https://developer-new.mozilla.org/en-US/demos/detail/the-planetarium gives me:

Traceback (most recent call last):

  File "/data/www/developer.mozilla.org/kuma/vendor/src/django/django/core/handlers/base.py", line 100, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/www/developer.mozilla.org/kuma/apps/demos/views.py", line 110, in detail
    'more_by': more_by

  File "/data/www/developer.mozilla.org/kuma/vendor/src/jingo/jingo/__init__.py", line 78, in render
    rendered = render_to_string(request, template, context)

  File "/data/www/developer.mozilla.org/kuma/vendor/src/jingo/jingo/__init__.py", line 96, in render_to_string
    return template.render(**get_context())

  File "/usr/lib64/python2.6/site-packages/jinja2/environment.py", line 891, in render
    return self.environment.handle_exception(exc_info, True)

  File "/data/www/developer.mozilla.org/kuma/apps/demos/templates/demos/detail.html", line 4, in top-level template code
    {% set short_url = full_url | bitly_shorten %}

  File "/data/www/developer.mozilla.org/kuma/apps/demos/templates/demos/base.html", line 1, in top-level template code
    {% extends "base.html" %}

  File "/data/www/developer.mozilla.org/kuma/templates/base.html", line 161, in top-level template code
    {% block content %}{% endblock %}

  File "/data/www/developer.mozilla.org/kuma/apps/demos/templates/demos/detail.html", line 226, in block "content"
    {{ comments_tree(request, submission, get_threaded_comment_tree(submission)) }}

  File "/data/www/developer.mozilla.org/kuma/apps/demos/helpers.py", line 332, in get_threaded_comment_tree
    flat = ThreadedComment.public.get_tree(content_object, root=tree_root)

  File "/data/www/developer.mozilla.org/kuma/vendor/packages/django-threadedcomments/threadedcomments/models.py", line 85, in get_tree
    to_return.extend(dfs(child, children, 0))

  File "/data/www/developer.mozilla.org/kuma/vendor/packages/django-threadedcomments/threadedcomments/models.py", line 38, in dfs
    if subnode.parent and subnode.parent.id == node.id:

  File "/data/www/developer.mozilla.org/kuma/vendor/src/django/django/db/models/fields/related.py", line 313, in __get__
    rel_obj = QuerySet(self.field.rel.to).using(db).get(**params)

  File "/data/www/developer.mozilla.org/kuma/vendor/src/django/django/db/models/query.py", line 347, in get
    % self.model._meta.object_name)

DoesNotExist: ThreadedComment matching query does not exist.
FWIW, demo studio data on -new is kind of throwaway right now, and I think a migration from current prod to -new died halfway through.

If you can't reproduce this on developer.mozilla.org, I'd say this will probably be fixed by bug 773480
Depends on: 773480
Priority: -- → P2
(Assignee)

Updated

5 years ago
Version: Kuma → unspecified
(Assignee)

Updated

5 years ago
Component: Website → Landing pages
Product: Mozilla Developer Network → Mozilla Developer Network
Stephen: Can you reproduce this on developer.mozilla.org?
Flags: needinfo?(stephen.donner)
(Reporter)

Comment 3

5 years ago
(In reply to John Karahalis [:openjck] from comment #2)
> Stephen: Can you reproduce this on developer.mozilla.org?

Nope!

[11:36:39.945] GET https://developer.mozilla.org/en-US/demos/detail/the-planetarium [HTTP/1.1 200 OK 313ms]
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(stephen.donner)
Resolution: --- → DUPLICATE
Duplicate of bug: 773480
You need to log in before you can comment on or make changes to this bug.