Closed Bug 778012 Opened 7 years ago Closed 5 years ago

Mac tabs have flickering gray artifacts (near favicon or close button) when resizing window

Categories

(Core :: Layout, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox16 --- unaffected
firefox17 - affected

People

(Reporter: cpeterson, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [See comment 12 & 14 for STR][browser.tabs.onTop must be set to false to repro])

Attachments

(2 files)

Attached image Favicon_artifact.png
Please see the attached screenshot. This problem is intermittent (about 5% repro), but seems to happen most often with slow-loading tabs or when opening many tabs.

Once a tab's favicon has the gray artifacts, reloading the page does not seem to make the problem go away.

I believe this is a regression in Nightly 17 (2012-07-21). Here is the pushlog from build 2012-07-20 to 2012-07-21:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3a05d298599e&tochange=446b788ab99d
Attached image X_Button_artifact.png
Some tabs also have gray artifacts on the right edge of the tabs' close [X] buttons.
Component: Tabbed Browser → Theme
I believe this regression first appeared in Nightly 17 (2012-07-21). Here is the pushlog from build 2012-07-20 to 2012-07-21:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3a05d298599e&tochange=446b788ab99d
btw, the gray artifacts only show up on the currently selected tab.
Bug 767779 is in that range, but so is its back-out. Are you sure the range is accurate?
Component: Theme → Tabbed Browser
Component: Tabbed Browser → Theme
Gavin, my regression range is fuzzy. I know the upper bound is valid (because I can repro the bug), but the lower bound may be wrong. Finding the "no repro" build for an intermittent bug requires some luck, but I can test again. :)
I retested some earlier builds and I am still pretty sure that Nightly 07-21 is the guilty build. I can easily reproduce the bug in Nightly 07-21, but I haven't seen it once in Nightly 07-20, even after loading ~50 tabs and restarting browser a few times.
We need a smaller range.
I bisected mozilla-central's Tinderbox builds. I think I have narrowed the regression window to:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6dae57cd2f85&tochange=045c11dd41a6

This window is still large, but at least it excludes one big merge from mozilla-inbound (cset 3337f0685b75).

This window includes bug 767779 (without its backout), but from what I can tell, the backout didn't affect favicon artifacts because I can still reproduce them with recent Nightly builds.
Version: unspecified → Trunk
Unless somebody has a clue what change caused this or how else to tackle this bug, we need to narrow down the range further.
jwatt, I believe this favicon artifact bug is a regression from your bug 614732.

I built Firefox locally and bisected the changesets in the regression window. This changeset for bug 614732 was the regression point:

https://hg.mozilla.org/mozilla-central/rev/62f19ed60528
What version of OS X are you using, and can you give more precise steps to reproduce? I've loaded 50 or so tabs with random pages into the build from the 21st and I haven't seen this.
I can reproduce the bug on three MacBook Pros: one running OS X 10.6.8 and two running OS X 10.7.4.

I've found easier, 100% STR:
1. Open 3 tabs
2. Click focus to the middle tab
3. Slowly resize the window horizontally
4. Gray artifacts will flicker to the left of the favicon and right of the close button

If you resize the window when the left-most tab is selected, only the close button artifacts are visible. When the right-most tab is selected, only the favicon artifacts are visible. Selecting the middle tab just makes it easier to repro both artifacts.

I think my previous "open many tabs" STR depended on tabs randomly landing on a specific pixel offset. Sorry for the time you invested opening 50 tabs! <:)
Summary: Favicons intermittently have gray artifacts on icon's left edge → Mac tabs have flickering gray artifacts (near favicon or close button) when resizing window
(In reply to Chris Peterson (:cpeterson) from comment #12)
> Sorry for the time you invested opening 50 tabs! <:)

Not at all. Reliable STRs can be hard to come by.

I still can't reproduce on OS X 10.7.4 though, I'm afraid. (Either in latest m-c nightly, or in the 2012-07-21-03-05-55-mozilla-central build.) What is the URL you're loading in the middle tab?
Any URL works, including about:blank.

I think the artifacts only appear when the tab width has been shrunk. That is why resizing the window horizontally and opening many tabs worked for my previous STR.

STR 3:
1. Open a few tabs.
2. Resize the window horizontally to zero width.
3. Slowly make the window larger again.
4. As the narrow tabs started to widen, the artifacts will flicker.
I totally can't reproduce this. I noticed that there are actually two m-c builds from the 21st, but I can't reproduce with either. Made the window wider very, very slowly, pixel by pixel. Nothing.

Do you have any add-ons installed in your profile, or any prefs changed? (I do not.) What model of mac do you have? I have a late 2011 MBP.
I was not able reproduce the bug in a clean profile until I unset "Tabs on Top". When the tabs hang below the Bookmarks Toolbar, I can repro the flickering artifacts. When the tabs are on top, I can't.

Apparently, "Tabs on Top" is no longer in the menus, but you can toggle the "browser.tabs.onTop" setting in about:config.
Blocks: 614732
Component: Theme → Layout
Product: Firefox → Core
Thanks for nailing down the regression range, Chris!
(In reply to Chris Peterson (:cpeterson) from comment #16)
> I was not able reproduce the bug in a clean profile until I unset "Tabs on
> Top". When the tabs hang below the Bookmarks Toolbar, I can repro the
> flickering artifacts. When the tabs are on top, I can't.

So given that the vast majority of users will not be seeing this, can someone on the UI team comment on how high a priority this bug is?

Can someone also point me to the relevant SVG fragments in the Firefox code? Better yet, if someone can turn this into a content-only testcase that would be even better.
As Jonathan points out in comment 18, the number of users who will see this is quite small so I'm untracking and the fix for this can be nominated for uplift when it's ready.
Whiteboard: [See comment 12 & 14 for STR][browser.tabs.onTop must be set to false to repro]
Bug 1005868 comment 0 says that browser.tabs.onTop has been removed.
Assignee: jwatt → nobody
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.